summaryrefslogtreecommitdiffstats
path: root/CMake
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--CMake/config.h.in3
-rw-r--r--CMakeLists.txt4
2 files changed, 5 insertions, 2 deletions
diff --git a/CMake/config.h.in b/CMake/config.h.in
index 65f983f..607f9d5 100644
--- a/CMake/config.h.in
+++ b/CMake/config.h.in
@@ -5,6 +5,9 @@
/* Define if we have the timegm() function */
#cmakedefine HAVE_TIMEGM
+/* Define if we have the gnutls library for TLS */
+#cmakedefine HAVE_GNUTLS
+
/* Define if we have the zlib library for gzip */
#cmakedefine HAVE_ZLIB
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9036b3d..3a2677f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,7 +91,7 @@ if (BERKELEY_FOUND)
set(HAVE_BDB 1)
endif()
-find_package(GnuTLS REQUIRED)
+find_package(GnuTLS)
if (GNUTLS_FOUND)
set(HAVE_GNUTLS 1)
endif()
@@ -206,7 +206,7 @@ endif()
# Configure some variables like package, version and architecture.
set(PACKAGE ${PROJECT_NAME})
set(PACKAGE_MAIL "APT Development Team <deity@lists.debian.org>")
-set(PACKAGE_VERSION "2.7.13")
+set(PACKAGE_VERSION "2.7.14")
string(REGEX MATCH "^[0-9.]+" PROJECT_VERSION ${PACKAGE_VERSION})
if (NOT DEFINED DPKG_DATADIR)