summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:03:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:03:18 +0000
commitf4acb49ea148cdd899f7f29f1591c7bc853c2135 (patch)
treeb62d60873864065d6428a84a119dd8a3c90f1397 /pyproject.toml
parentAdding upstream version 1:2.11. (diff)
downloadbash-completion-f4acb49ea148cdd899f7f29f1591c7bc853c2135.tar.xz
bash-completion-f4acb49ea148cdd899f7f29f1591c7bc853c2135.zip
Adding upstream version 1:2.12.0.upstream/1%2.12.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml29
1 files changed, 27 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 2581528..83d0112 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,28 @@
-[tool.black]
+[tool.ruff]
line-length = 79
-target-version = ["py34", "py35", "py36", "py37", "py38"]
+target-version = "py37"
+lint.select = ["E", "F", "B"]
+lint.ignore = [
+ # https://docs.astral.sh/ruff/formatter/#conflicting-lint-rules
+ # (keep order of ignores here same as ^there for maintainability)
+ "W191",
+ "E111",
+ "E114",
+ "E117",
+ "D206",
+ "D300",
+ "Q000",
+ "Q001",
+ "Q002",
+ "Q003",
+ "COM812",
+ "COM819",
+ "ISC001",
+ "ISC002",
+ "E501",
+]
+fix = true
+
+[tool.ruff.lint.isort]
+known-first-party = ["conftest"]
+known-third-party = ["pexpect", "pytest"]