summaryrefslogtreecommitdiffstats
path: root/test/fixtures/make/test2/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:03:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:03:18 +0000
commitf4acb49ea148cdd899f7f29f1591c7bc853c2135 (patch)
treeb62d60873864065d6428a84a119dd8a3c90f1397 /test/fixtures/make/test2/Makefile
parentAdding upstream version 1:2.11. (diff)
downloadbash-completion-f4acb49ea148cdd899f7f29f1591c7bc853c2135.tar.xz
bash-completion-f4acb49ea148cdd899f7f29f1591c7bc853c2135.zip
Adding upstream version 1:2.12.0.upstream/1%2.12.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/fixtures/make/test2/Makefile')
-rw-r--r--test/fixtures/make/test2/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/fixtures/make/test2/Makefile b/test/fixtures/make/test2/Makefile
new file mode 100644
index 0000000..835b514
--- /dev/null
+++ b/test/fixtures/make/test2/Makefile
@@ -0,0 +1,23 @@
+# makefile
+
+all: abc/xyz
+.PHONY: abc/xyz
+abc/xyz 123/xaa 123/xbb:
+ mkdir -p $(@:/%=)
+ date > $@
+
+sub1test/bar/alpha sub1test/bar/beta:
+ mkdir -p $(@:/%=)
+ date > $@
+
+sub2test/bar/alpha:
+ mkdir -p $(@:/%=)
+ date > $@
+
+sub3test/bar/alpha sub3test/foo/alpha:
+ mkdir -p $(@:/%=)
+ date > $@
+
+sub4test/bar/alpha sub4test/bar/beta sub4test2/foo/gamma:
+ mkdir -p $(@:/%=)
+ date > $@