summaryrefslogtreecommitdiffstats
path: root/.editorconfig
diff options
context:
space:
mode:
Diffstat (limited to '.editorconfig')
-rw-r--r--.editorconfig18
1 files changed, 18 insertions, 0 deletions
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 0000000..85032d1
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,18 @@
+[*]
+indent_style = space
+indent_size = 4
+tab_width = 8
+end_of_line = lf
+charset = utf-8
+trim_trailing_whitespace = true
+insert_final_newline = true
+max_line_length = 79
+# for shfmt
+function_next_line = true
+switch_case_indent = true
+
+[Makefile.am]
+indent_style = tab
+
+[*.{yml,yaml}]
+indent_size = 2