summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 26f3c7c..27366b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ pkgdata_DATA = bash_completion
# Empty, but here just to get the compat dir created with install
compatdir = $(sysconfdir)/bash_completion.d
-compat_DATA =
+compat_DATA = bash_completion.d/000_bash_completion_compat.bash
profiledir = $(sysconfdir)/profile.d
profile_DATA = bash_completion.sh
@@ -28,10 +28,11 @@ cmakeconfig_DATA = bash-completion-config.cmake \
CLEANFILES = bash_completion.sh bash-completion.pc \
bash-completion-config.cmake bash-completion-config-version.cmake
-EXTRA_DIST = CHANGES $(pkgdata_DATA) bash_completion.sh.in .dir-locals.el \
+EXTRA_DIST = CHANGELOG.md $(pkgdata_DATA) bash_completion.sh.in .dir-locals.el \
.editorconfig README.md CONTRIBUTING.md pyproject.toml .perltidyrc \
.shellcheckrc bash-completion.pc.in bash-completion-config.cmake.in \
- bash-completion-config-version.cmake.in setup-symlinks.sh
+ bash-completion-config-version.cmake.in setup-symlinks.sh \
+ $(compat_DATA)
install-data-hook:
tmpfile=`mktemp $${TMPDIR:-/tmp}/bash_completion.XXXXXX` && \