summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9f1abc2..83a6f12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,14 @@
AC_PREREQ([2.60])
-AC_INIT([bash-completion], [2.11])
-AM_INIT_AUTOMAKE([foreign dist-xz no-dist-gzip -Wall -Wno-portability -Werror])
+AC_INIT([bash-completion], [2.12.0]) dnl x-release-please-version
+dnl tar-pax for portable UTF-8 handling
+AM_INIT_AUTOMAKE([
+ foreign dist-xz no-dist-gzip tar-pax -Wall -Wno-portability -Werror
+])
AC_PROG_LN_S
AC_PROG_MKDIR_P
AC_PROG_SED
AC_ARG_WITH([pytest],[ --with-pytest=executable],[PYTEST="$withval"])
-if test -z "$PYTEST"; then
+if test "x$PYTEST" = x; then
AC_CHECK_PROGS([PYTEST],[pytest pytest-3],[pytest])
fi
AC_CONFIG_FILES([
@@ -14,6 +17,8 @@ completions/Makefile
doc/Makefile
helpers/Makefile
test/Makefile
+test/fallback/Makefile
+test/fallback/completions/Makefile
test/t/Makefile
test/t/unit/Makefile
])