summaryrefslogtreecommitdiffstats
path: root/test/fixtures/make/test2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/fixtures/make/test2/Makefile')
-rw-r--r--test/fixtures/make/test2/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/fixtures/make/test2/Makefile b/test/fixtures/make/test2/Makefile
new file mode 100644
index 0000000..835b514
--- /dev/null
+++ b/test/fixtures/make/test2/Makefile
@@ -0,0 +1,23 @@
+# makefile
+
+all: abc/xyz
+.PHONY: abc/xyz
+abc/xyz 123/xaa 123/xbb:
+ mkdir -p $(@:/%=)
+ date > $@
+
+sub1test/bar/alpha sub1test/bar/beta:
+ mkdir -p $(@:/%=)
+ date > $@
+
+sub2test/bar/alpha:
+ mkdir -p $(@:/%=)
+ date > $@
+
+sub3test/bar/alpha sub3test/foo/alpha:
+ mkdir -p $(@:/%=)
+ date > $@
+
+sub4test/bar/alpha sub4test/bar/beta sub4test2/foo/gamma:
+ mkdir -p $(@:/%=)
+ date > $@