summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-16 16:32:54 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-16 16:32:54 +0000
commit0c3a6cc734f7c6eef1d3d8ab8329cc39b7d79046 (patch)
tree7839c3063f26cc21bbbade27c2cd6216a5ca15f1
parentAdding upstream version 20211009. (diff)
downloadbfh-metapackages-0c3a6cc734f7c6eef1d3d8ab8329cc39b7d79046.tar.xz
bfh-metapackages-0c3a6cc734f7c6eef1d3d8ab8329cc39b7d79046.zip
Adding debian version 20211009-21.debian/20211009-21
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xdebian/bfh-container.postrm30
-rwxr-xr-xdebian/bfh-container.preinst32
-rw-r--r--debian/changelog219
-rw-r--r--debian/control309
-rw-r--r--debian/copyright25
-rwxr-xr-xdebian/local/shutdown13
-rw-r--r--debian/local/shutdown.txt6
-rwxr-xr-xdebian/rules29
-rw-r--r--debian/source/format1
-rw-r--r--debian/upstream/signing-key.asc13
10 files changed, 677 insertions, 0 deletions
diff --git a/debian/bfh-container.postrm b/debian/bfh-container.postrm
new file mode 100755
index 0000000..ec69346
--- /dev/null
+++ b/debian/bfh-container.postrm
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ remove)
+ for FILE in halt poweroff reboot shutdown coldreboot
+ do
+ dpkg-divert --package bfh-container --quiet --remove --rename --divert /lib/container/divert/${FILE}.orig /sbin/${FILE}
+ done
+
+ for FILE in pm-hibernate pm-suspend pm-suspend-hybrid
+ do
+ dpkg-divert --package bfh-container --quiet --remove --rename --divert /lib/container/divert/${FILE}.orig /usr/sbin/${FILE}
+ done
+ ;;
+
+ purge|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
+
+ ;;
+
+ *)
+ echo "postrm called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/bfh-container.preinst b/debian/bfh-container.preinst
new file mode 100755
index 0000000..335d160
--- /dev/null
+++ b/debian/bfh-container.preinst
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ install|upgrade)
+ mkdir -p /lib/container/divert
+
+ for FILE in halt poweroff reboot shutdown coldreboot
+ do
+ dpkg-divert --package bfh-container --quiet --add --rename --divert /lib/container/divert/${FILE}.orig /sbin/${FILE}
+ done
+
+ for FILE in pm-hibernate pm-suspend pm-suspend-hybrid
+ do
+ dpkg-divert --package bfh-container --quiet --add --rename --divert /lib/container/divert/${FILE}.orig /usr/sbin/${FILE}
+ done
+ ;;
+
+ abort-upgrade)
+
+ ;;
+
+ *)
+ echo "preinst called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..0338084
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,219 @@
+bfh-metapackages (20211009-21) sid; urgency=medium
+
+ * Uploading to sid.
+ * Adding ipcalc-ng to bfh-base-system dependencies.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Wed, 11 Oct 2023 11:26:46 +0200
+
+bfh-metapackages (20211009-20) sid; urgency=medium
+
+ * Uploading to sid.
+ * Adding conflicts/replaces against progress-linux-container (Closes:
+ #1034911).
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Wed, 03 May 2023 11:21:33 +0200
+
+bfh-metapackages (20211009-19) sid; urgency=medium
+
+ * Uploading to sid.
+ * Replacing individual gnome-shell-extensions suggests with
+ conglomeration package.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Sun, 05 Feb 2023 11:54:38 +0100
+
+bfh-metapackages (20211009-18) sid; urgency=medium
+
+ * Uploading to sid.
+ * Adding gnome-shell-extension-hibernate-status to bfh-gnome-desktop
+ suggests.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Mon, 30 Jan 2023 12:14:32 +0100
+
+bfh-metapackages (20211009-17) sid; urgency=medium
+
+ * Uploading to sid.
+ * Shortening knot package list in bfh-base-system for bookworm.
+ * Reordering packages in bfh-base-system for consistency.
+ * Adding zutils to bfh-base-system depends.
+ * Shortening systemd package list in bfh-base-system for bookworm.
+ * Removing crudini from bfh-base-system depends.
+ * Adding ptpython to bfh-base-system depends.
+ * Shortening policykit package list in bfh-container for bookworm.
+ * Removing rng-tools in bfh-host depends.
+ * Wrapping firmware packages in bfh-host depends.
+ * Removing intel-isdct in bfh-host suggests.
+ * Removing old webext-umatrix suggests in bfh-desktop.
+ * Adding gnome-shell-extensions to bfh-gnome-desktop.
+ * Removing pass related packages from bfh-desktop depends.
+ * Removing duplicated whois in bfh-desktop depends.
+ * Removing seahorse-nautilus from bfh-gnome-desktop depends.
+ * Removing ioping from bfh-base-system depends.
+ * Harmonizing coments in control.
+ * Prefering mmdebstrap over debootstrap in bfh-container-server.
+ * Removing inactive sub-packages in control for bookworm.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Thu, 26 Jan 2023 17:24:59 +0100
+
+bfh-metapackages (20211009-16) sid; urgency=medium
+
+ * Uploading to sid.
+ * Removing watch file for now.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Tue, 24 Jan 2023 13:55:33 +0100
+
+bfh-metapackages (20211009-15) sid; urgency=medium
+
+ * Uploading to sid.
+ * Removing obsolete webext-https-everywhere from bfh-desktop.
+ * Updating ublock-origin depends (Closes: #1029286).
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Mon, 23 Jan 2023 09:29:46 +0100
+
+bfh-metapackages (20211009-14) sid; urgency=medium
+
+ * Uploading to sid.
+ * Adding whois to bfh-base-system depends.
+ * Updating to standards version 4.6.2.
+ * Updating policykit dependencies (Closes: #1025544).
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Wed, 18 Jan 2023 09:13:21 +0100
+
+bfh-metapackages (20211009-13) sid; urgency=medium
+
+ * Uploading to sid.
+ * Correcting alternative depends against knot-dnsutils to ensure that
+ knot-dnssecutils is properly pulled in.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Mon, 26 Sep 2022 18:33:05 +0200
+
+bfh-metapackages (20211009-12) sid; urgency=medium
+
+ * Uploading to sid.
+ * Adding knot-dnssecutils to progress-linux-base-system depends.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Wed, 21 Sep 2022 11:48:56 +0200
+
+bfh-metapackages (20211009-11) sid; urgency=medium
+
+ * Uploading to sid.
+ * Updating to standards version 4.6.1.
+ * Including knot-resolver in bfh-hosts only, rather than bfh-container.
+ * Adding bfh-server-r metapackage.
+ * Adding bfh-server-rstudio metapackage.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Thu, 05 May 2022 13:47:57 +0200
+
+bfh-metapackages (20211009-10) sid; urgency=medium
+
+ * Uploading to sid.
+ * Removing ifupdown related packages in order to switch to systemd-
+ networkd on container-servers.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Thu, 28 Apr 2022 14:21:58 +0200
+
+bfh-metapackages (20211009-9) sid; urgency=medium
+
+ * Uploading to sid.
+ * Adding traceroute to bfh-base-system depends.
+ * Adding zstd to bfh-base-system.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Thu, 21 Apr 2022 10:46:13 +0200
+
+bfh-metapackages (20211009-8) sid; urgency=medium
+
+ * Uploading to sid.
+ * Adding systemd-oomd to bfh-base-system depends.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Thu, 17 Feb 2022 05:25:07 +0100
+
+bfh-metapackages (20211009-7) sid; urgency=medium
+
+ * Uploading to sid.
+ * Replacing ntp in favour of systemd-timesyncd in progress-linux-host.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Thu, 20 Jan 2022 07:16:24 +0100
+
+bfh-metapackages (20211009-6) sid; urgency=medium
+
+ * Uploading to sid.
+ * Updating packaging copyright for 2022.
+ * Adding lldpd to bfh-container-server depends.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Thu, 06 Jan 2022 15:00:48 +0100
+
+bfh-metapackages (20211009-5) sid; urgency=medium
+
+ * Uploading to sid.
+ * Removing some more old gnome-shell-extensions.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Mon, 08 Nov 2021 13:23:30 +0100
+
+bfh-metapackages (20211009-4) sid; urgency=medium
+
+ * Uploading to sid.
+ * Removing outdated gnome-shell-extensions entirely.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Wed, 03 Nov 2021 03:11:23 +0100
+
+bfh-metapackages (20211009-3) sid; urgency=medium
+
+ * Uploading to sid.
+ * Skipping gnome-shell-extension-hide-activities until it is updated for
+ GNOME 40.
+ * Skipping gnome-shell-extension-multi-monitors until it is updated for
+ GNOME 40.
+
+ -- Daniel Baumann <mail@daniel-baumann.ch> Tue, 02 Nov 2021 13:15:23 +0100
+
+bfh-metapackages (20211009-2) sid; urgency=medium
+
+ * Uploading to sid.
+ * Adding needrestart to bfh-base-system depends.
+ * Removing gnome-shell-extension-remove-dropdown-arrows, not needed
+ anymore with newer GNOME (Closes: #997074).
+ * Dropping pre-bookworm hardlink depends in bfh-base-system.
+
+ -- Daniel Baumann <mail@daniel-baumann.ch> Wed, 27 Oct 2021 08:21:55 +0200
+
+bfh-metapackages (20211009-1) sid; urgency=medium
+
+ * Uploading to sid.
+ * Merging upstream version 20211009.
+ * Adding python3-docutils build-depends.
+ * Depending on hardlink only on pre-bookworm systems.
+ * Adding jq to bfh-base-system depends.
+ * Adding shutdown handling in bfh-container.
+ * Removing sysstat from bfh-base-system depends.
+
+ -- Daniel Baumann <mail@daniel-baumann.ch> Fri, 08 Oct 2021 20:06:21 +0200
+
+bfh-metapackages (20211008-1) sid; urgency=medium
+
+ * Uploading to sid.
+ * Merging upstream version 20211008.
+ * Updating to standards version 4.6.0.
+ * Dropping references to exfat-fuse and exfat-utils for bookworm and
+ newer (Closes: #992285).
+ * Adding knot-resolver on arm64.
+ * Removing pre-bullseye task-print-server alternative depends.
+ * Removing pre-bullseye enigmail alternative depends.
+ * Removing pre-bullseye gnome-shell-extension-bluetooth-quick-connect
+ alternative depends.
+ * Updating years in copyright file.
+ * Using https reference in copyright file.
+
+ -- Daniel Baumann <mail@daniel-baumann.ch> Fri, 08 Oct 2021 13:48:11 +0200
+
+bfh-metapackages (20210101-2) sid; urgency=medium
+
+ * Uploading to sid.
+ * Adding breaks exim4-config in bfh-server, thanks to Andreas Beckmann
+ <anbe@debian.org> (Closes: #986389).
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Tue, 06 Apr 2021 12:51:07 +0200
+
+bfh-metapackages (20210101-1) sid; urgency=medium
+
+ * Initial upload to sid.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Sat, 13 Mar 2021 07:17:16 +0100
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..0098ce7
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,309 @@
+Source: bfh-metapackages
+Section: metapackages
+Priority: optional
+Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
+Build-Depends:
+ debhelper-compat (= 13),
+ python3-docutils,
+Rules-Requires-Root: no
+Standards-Version: 4.6.2
+Homepage: https://bfh.science
+Vcs-Browser: https://git.progress-linux.org/users/daniel.baumann/debian/packages/bfh-metapackages
+Vcs-Git: https://git.progress-linux.org/users/daniel.baumann/debian/packages/bfh-metapackages
+
+Package: bfh-base-system
+Section: metapackages
+Architecture: any
+Depends:
+ ${misc:Depends},
+ task-ssh-server,
+# bash
+ bash-completion,
+ powerline,
+ powerline-gitstatus,
+# debian
+ apt-utils,
+ debconf-utils,
+ needrestart,
+# knot
+ knot-dnsutils,
+ knot-dnssecutils,
+ knot-host,
+# ldap
+ sssd,
+ sssd-tools,
+ libnss-sss,
+ libpam-sss,
+# lzip
+ plzip,
+ tarlz,
+ zutils,
+# systemd
+ libpam-systemd,
+ systemd-oomd,
+# other
+ acl,
+ bc,
+ ca-certificates,
+ gawk,
+ git,
+ gnupg,
+ htop,
+ ipcalc-ng,
+ jq,
+ less,
+ lnav,
+ lsb-release,
+ lynx,
+ man-db,
+ mc,
+ mtr-tiny,
+ openssl,
+ psmisc,
+ python3,
+ ptpython,
+ rsync,
+ screen,
+ sudo,
+ tcpdump,
+ traceroute,
+ vim,
+ wget,
+ whois,
+ zstd,
+Conflicts:
+ resolvconf,
+Recommends:
+# knot-resolver
+ knot-resolver [amd64 arm64 armhf armel i386],
+ socat,
+Description: BFH - Base System Metapackage
+ Bern University of Applied Sciences (BFH) provides Debian-based images and
+ systems to its users and everyone else interested in the form of a Debian
+ Derrivative.
+ .
+ This package is a metapackage defining the package selection for the
+ BFH Base System.
+
+Package: bfh-container
+Section: metapackages
+Architecture: all
+Depends:
+ ${misc:Depends},
+ bfh-base-system,
+# systemd
+ dbus,
+ polkitd,
+ systemd-sysv,
+Conflicts:
+ molly-guard,
+ progress-linux-container,
+Replaces:
+ molly-guard,
+ progress-linux-container,
+Enhances:
+ bfh-base-system,
+Description: BFH - Container Metapackage
+ Bern University of Applied Sciences (BFH) provides Debian-based images and
+ systems to its users and everyone else interested in the form of a Debian
+ Derrivative.
+ .
+ This package is a metapackage to be installed in a container (systemd-nspawn).
+
+Package: bfh-host
+Section: metapackages
+Architecture: any
+Depends:
+ ${misc:Depends},
+ bfh-base-system,
+# cryptsetup
+ cryptsetup-bin,
+ keyutils,
+ plymouth,
+# firmware-free
+ firmware-linux-free,
+# knot-resolver
+ knot-resolver [amd64 arm64 armhf armel i386],
+ socat,
+# monitoring
+ spectre-meltdown-checker,
+# other
+ dmidecode [amd64 arm64 armhf i386],
+ ethtool,
+ gpm,
+ hdparm,
+ nvme-cli,
+ parted,
+ smartmontools,
+ systemd-timesyncd,
+Suggests:
+# bash
+ fonts-powerline-extra,
+# firmware-nonfree (non-free)
+ firmware-linux-nonfree,
+ firmware-misc-nonfree,
+# firmware (non-free)
+ firmware-ast,
+# microcode (contrib, non-free)
+ iucode-tool,
+ amd64-microcode,
+ intel-microcode,
+# other (third-party)
+ supermicro-ipmicfg,
+Enhances:
+ bfh-base-system,
+Description: BFH - Host Metapackage
+ Bern University of Applied Sciences (BFH) provides Debian-based images and
+ systems to its users and everyone else interested in the form of a Debian
+ Derrivative.
+ .
+ This package is a metapackage to be installed on a host system (physical or
+ virtual).
+
+Package: bfh-desktop
+Section: metapackages
+Architecture: any
+Depends:
+ ${misc:Depends},
+ bfh-base-system,
+ task-desktop,
+ task-laptop,
+ cups,
+# bash
+ fonts-powerline,
+# firefox
+ firefox | firefox-esr | www-browser,
+ webext-foxyproxy,
+ webext-privacy-badger,
+ webext-ublock-origin-firefox,
+# filesystems
+ dosfstools,
+ exfatprogs,
+ nfs-common,
+ ntfs-3g,
+ samba-common,
+ sshfs,
+# gimp
+ gimp,
+ gimp-plugin-registry,
+# inkscape
+ inkscape,
+ inkscape-open-symbols,
+# liferea
+ liferea,
+ gir1.2-gstreamer-1.0,
+ gir1.2-notify-0.7,
+# network-manager
+ network-manager-config-connectivity-debian,
+ network-manager-ssh,
+# thunderbird
+ thunderbird [amd64 arm64 i386],
+# zip
+ unzip,
+ zip,
+# other
+ apg,
+ nwipe,
+ symlinks,
+Suggests:
+# deluge
+ deluge-gtk, deluged,
+# virtualbox (contrib, non-free)
+ virtualbox,
+ virtualbox-dkms,
+ virtualbox-ext-pack,
+ virtualbox-qt,
+Enhances:
+ bfh-base-system,
+Description: BFH - Desktop Metapackage
+ Bern University of Applied Sciences (BFH) provides Debian-based images and
+ systems to its users and everyone else interested in the form of a Debian
+ Derrivative.
+ .
+ This package is a metapackage to be installed on a desktop.
+
+Package: bfh-gnome-desktop
+Section: metapackages
+Architecture: all
+Depends:
+ ${misc:Depends},
+ bfh-desktop,
+ task-gnome-desktop,
+# gnome-shell-extensions
+ gnome-shell-extension-bluetooth-quick-connect,
+ gnome-shell-extension-impatience,
+ gnome-shell-extension-no-annoyance,
+# nautilus
+ nautilus-admin,
+# network-manager
+ network-manager-ssh-gnome,
+Suggests:
+ gnome-shell-extensions-extra,
+Enhances:
+ bfh-base-system,
+ bfh-desktop,
+Description: BFH - GNOME Desktop Metapackage
+ Bern University of Applied Sciences (BFH) provides Debian-based images and
+ systems to its users and everyone else interested in the form of a Debian
+ Derrivative.
+ .
+ This package is a metapackage defining the package selection for the
+ BFH GNOME Desktop.
+
+Package: bfh-server
+Section: metapackages
+Architecture: all
+Depends:
+ ${misc:Depends},
+ bfh-base-system,
+# other
+ localepurge,
+ logrotate,
+ molly-guard | bfh-container,
+ postfix,
+ safe-rm,
+Breaks:
+ exim4-config,
+Enhances:
+ bfh-base-system,
+Description: BFH - Server Metapackage
+ Bern University of Applied Sciences (BFH) provides Debian-based images and
+ systems to its users and everyone else interested in the form of a Debian
+ Derrivative.
+ .
+ This package is a metapackage to be installed on a server.
+
+Package: bfh-container-server
+Section: metapackages
+Architecture: all
+Depends:
+ ${misc:Depends},
+ bfh-server,
+# container-tools
+ open-infrastructure-container-tools,
+ curl,
+ mmdebstrap | debootstrap,
+ irker,
+ pv,
+ bridge-utils,
+# monitoring
+ netdata,
+ netdata-apache2,
+ netdata-plugins-python,
+# web
+ apache2,
+# other
+ lldpd,
+ numad,
+Suggests:
+ ttyd,
+Enhances:
+ bfh-base-system,
+ bfh-server,
+Description: BFH - Container Server Metapackage
+ Bern University of Applied Sciences (BFH) provides Debian-based images and
+ systems to its users and everyone else interested in the form of a Debian
+ Derrivative.
+ .
+ This package is a metapackage defining the package selection for the
+ BFH Container Server.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..0687946
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,25 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: BFH Metapackages
+Upstream-Contact: BFH Linux System Administration <bfh-linux-sysadmin@lists.bfh.science>
+Source: https://get.bfh.science/packages/bfh-metapackages
+
+Files: *
+Copyright: 2013-2022 Daniel Baumann <daniel@debian.org>
+License: GPL-3+
+
+License: GPL-3+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, either version 3 of the License, or
+ (at your option) any later version.
+ .
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <https://www.gnu.org/licenses/>.
+ .
+ The complete text of the GNU General Public License
+ can be found in /usr/share/common-licenses/GPL-3 file.
diff --git a/debian/local/shutdown b/debian/local/shutdown
new file mode 100755
index 0000000..30e959d
--- /dev/null
+++ b/debian/local/shutdown
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+echo "${0}: disabled in systemd-nspawn container"
+
+if [ -e /etc/compute-tools/shutdown.txt ]
+then
+ cat /etc/compute-tools/shutdown.txt
+elif [ -e /usr/share/container/shutdown.txt ]
+then
+ cat /usr/share/container/shutdown.txt
+fi
+
+exit 1
diff --git a/debian/local/shutdown.txt b/debian/local/shutdown.txt
new file mode 100644
index 0000000..b082bf0
--- /dev/null
+++ b/debian/local/shutdown.txt
@@ -0,0 +1,6 @@
+
+Linux container share the kernel of the host system they are running on,
+there is no need to reboot just the container.
+
+However, please contact your system administrator to reboot this
+container from the host system.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..7bb7904
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,29 @@
+#!/usr/bin/make -f
+
+%:
+ dh ${@}
+
+override_dh_auto_install:
+ dh_auto_install -- DESTDIR=$(CURDIR)/debian/bfh-base-system
+
+execute_after_dh_auto_install:
+ # shutdown
+ mkdir -p debian/bfh-container/sbin
+ for FILE in halt poweroff reboot shutdown coldreboot; \
+ do \
+ cp debian/local/shutdown debian/bfh-container/sbin/$${FILE}; \
+ done
+
+ mkdir -p debian/bfh-container/usr/sbin
+ for FILE in pm-hibernate pm-suspend pm-suspend-hybrid; \
+ do \
+ cp debian/local/shutdown debian/bfh-container/usr/sbin/$${FILE}; \
+ done
+
+ mkdir -p debian/bfh-container/usr/share/container
+ cp debian/local/shutdown.txt debian/bfh-container/usr/share/container
+
+ # removing useless files
+ rm -f debian/tmp/usr/share/doc/*/CHANGELOG.txt
+ rm -f debian/tmp/usr/share/doc/*/LICENSE.txt
+ rm -f debian/tmp/usr/share/doc/*/VERSION.txt
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/upstream/signing-key.asc b/debian/upstream/signing-key.asc
new file mode 100644
index 0000000..f52ab7a
--- /dev/null
+++ b/debian/upstream/signing-key.asc
@@ -0,0 +1,13 @@
+-----BEGIN PGP PUBLIC KEY BLOCK-----
+
+mDMEWxFMYRYJKwYBBAHaRw8BAQdADzHSjCfMckc2n1ChpH0IblcfyMTv+PMUv2Ik
+a2s8DJ60JkRhbmllbCBCYXVtYW5uIDxkYW5pZWwuYmF1bWFubkBiZmguY2g+iJAE
+ExYIADgWIQRfK8Ys+mEzhHeP0xyFWZF4vm+F1gUCWxFMYQIbAwULCQgHAgYVCgkI
+CwIEFgIDAQIeAQIXgAAKCRCFWZF4vm+F1tggAP4mhRIFQQEjrXoPNaKl4HYSRnTc
+pyMPEZSqrqvsMzRnEQD+IpNTMSGGcmofnmrKcUdvJz/52sXQOLo4U1jRBE8SOQW4
+OARbEUxhEgorBgEEAZdVAQUBAQdAj3Hyc8bLWaKUCKcffqVCriSnOwyitWijZyvQ
+Fue69BUDAQgHiHgEGBYIACAWIQRfK8Ys+mEzhHeP0xyFWZF4vm+F1gUCWxFMYQIb
+DAAKCRCFWZF4vm+F1nHJAP9/KV68+pvdJua5+8wRbvRJgcHN/5cpbAlEZm1oqY++
+kQD/VOd/xSbTeOthPZ7UtvKx3xlFRaMKNMPRxH947EP7aA8=
+=ZdZo
+-----END PGP PUBLIC KEY BLOCK-----