summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:10:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:10:40 +0000
commit566fd589c5ee5d23902ef807f0fde30701b9db93 (patch)
tree6c661dce007545291cfc2f515a7af6cc15a418ff /Makefile
parentInitial commit. (diff)
downloadca-certificates-566fd589c5ee5d23902ef807f0fde30701b9db93.tar.xz
ca-certificates-566fd589c5ee5d23902ef807f0fde30701b9db93.zip
Adding upstream version 20240203.upstream/20240203upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..ce270f1
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,26 @@
+#
+# Makefile
+#
+
+CERTSDIR = /usr/share/ca-certificates
+SUBDIRS = mozilla
+
+all:
+ for dir in $(SUBDIRS); do \
+ $(MAKE) -C $$dir all; \
+ done
+
+clean:
+ for dir in $(SUBDIRS); do \
+ $(MAKE) -C $$dir clean; \
+ done
+
+install:
+ for dir in $(SUBDIRS); do \
+ mkdir $(DESTDIR)/$(CERTSDIR)/$$dir; \
+ $(MAKE) -C $$dir install CERTSDIR=$(DESTDIR)/$(CERTSDIR)/$$dir; \
+ done
+ for dir in sbin; do \
+ $(MAKE) -C $$dir install CERTSDIR=$(DESTDIR)/$(CERTSDIR)/$$dir; \
+ done
+