summaryrefslogtreecommitdiffstats
path: root/mozilla/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:10:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:10:40 +0000
commit566fd589c5ee5d23902ef807f0fde30701b9db93 (patch)
tree6c661dce007545291cfc2f515a7af6cc15a418ff /mozilla/Makefile
parentInitial commit. (diff)
downloadca-certificates-566fd589c5ee5d23902ef807f0fde30701b9db93.tar.xz
ca-certificates-566fd589c5ee5d23902ef807f0fde30701b9db93.zip
Adding upstream version 20240203.upstream/20240203upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'mozilla/Makefile')
-rw-r--r--mozilla/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/mozilla/Makefile b/mozilla/Makefile
new file mode 100644
index 0000000..a943473
--- /dev/null
+++ b/mozilla/Makefile
@@ -0,0 +1,20 @@
+#
+# Makefile
+#
+
+all:
+ python3 certdata2pem.py
+
+clean:
+ -rm -f *.crt
+
+install:
+ install -d $(CERTSDIR)
+ for p in *.crt; do \
+ install -m 644 $$p $(CERTSDIR)/$$p ; \
+ done
+
+update:
+ wget -Ocertdata.txt https://hg.mozilla.org/releases/mozilla-release/raw-file/default/security/nss/lib/ckfw/builtins/certdata.txt
+ wget -Onssckbi.h https://hg.mozilla.org/releases/mozilla-release/raw-file/default/security/nss/lib/ckfw/builtins/nssckbi.h
+ false