summaryrefslogtreecommitdiffstats
path: root/vendor/const-oid/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/const-oid/Cargo.toml')
-rw-r--r--vendor/const-oid/Cargo.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/vendor/const-oid/Cargo.toml b/vendor/const-oid/Cargo.toml
new file mode 100644
index 0000000..2d569dd
--- /dev/null
+++ b/vendor/const-oid/Cargo.toml
@@ -0,0 +1,58 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.57"
+name = "const-oid"
+version = "0.9.5"
+authors = ["RustCrypto Developers"]
+description = """
+Const-friendly implementation of the ISO/IEC Object Identifier (OID) standard
+as defined in ITU X.660, with support for BER/DER encoding/decoding as well as
+heapless no_std (i.e. embedded) support
+"""
+documentation = "https://docs.rs/const-oid"
+readme = "README.md"
+keywords = [
+ "iso",
+ "iec",
+ "itu",
+ "oid",
+]
+categories = [
+ "cryptography",
+ "data-structures",
+ "encoding",
+ "no-std",
+ "parser-implementations",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/formats/tree/master/const-oid"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.arbitrary]
+version = "1.1"
+features = ["derive"]
+optional = true
+
+[dev-dependencies.hex-literal]
+version = "0.3"
+
+[features]
+db = []
+std = []