summaryrefslogtreecommitdiffstats
path: root/vendor/curl/ci/run.sh
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/curl/ci/run.sh')
-rwxr-xr-xvendor/curl/ci/run.sh26
1 files changed, 26 insertions, 0 deletions
diff --git a/vendor/curl/ci/run.sh b/vendor/curl/ci/run.sh
new file mode 100755
index 0000000..6c2dae3
--- /dev/null
+++ b/vendor/curl/ci/run.sh
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+set -ex
+
+cargo test --target $TARGET --no-run
+# First test with no extra protocols enabled.
+cargo test --target $TARGET --no-run --features static-curl
+# Then with rustls TLS backend.
+cargo test --target $TARGET --no-run --features rustls,static-curl
+# Then with all extra protocols enabled.
+cargo test --target $TARGET --no-run --features static-curl,protocol-ftp,ntlm
+if [ -z "$NO_RUN" ]; then
+ cargo test --target $TARGET
+ cargo test --target $TARGET --features static-curl
+ cargo test --target $TARGET --features static-curl,protocol-ftp
+
+ # Note that `-Clink-dead-code` is passed here to suppress `--gc-sections` to
+ # help confirm that we're compiling everything necessary for curl itself.
+ RUSTFLAGS=-Clink-dead-code \
+ cargo run --manifest-path systest/Cargo.toml --target $TARGET
+ RUSTFLAGS=-Clink-dead-code \
+ cargo run --manifest-path systest/Cargo.toml --target $TARGET --features curl-sys/static-curl,curl-sys/protocol-ftp
+
+ cargo doc --no-deps --target $TARGET
+ cargo doc --no-deps -p curl-sys --target $TARGET
+fi