summaryrefslogtreecommitdiffstats
path: root/vendor/der/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/der/Cargo.toml')
-rw-r--r--vendor/der/Cargo.toml109
1 files changed, 109 insertions, 0 deletions
diff --git a/vendor/der/Cargo.toml b/vendor/der/Cargo.toml
new file mode 100644
index 0000000..83b77c1
--- /dev/null
+++ b/vendor/der/Cargo.toml
@@ -0,0 +1,109 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.65"
+name = "der"
+version = "0.7.8"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust embedded-friendly implementation of the Distinguished Encoding Rules
+(DER) for Abstract Syntax Notation One (ASN.1) as described in ITU X.690 with
+full support for heapless no_std targets
+"""
+readme = "README.md"
+keywords = [
+ "asn1",
+ "crypto",
+ "itu",
+ "pkcs",
+]
+categories = [
+ "cryptography",
+ "data-structures",
+ "encoding",
+ "no-std",
+ "parser-implementations",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/formats/tree/master/der"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.arbitrary]
+version = "1.0"
+features = ["derive"]
+optional = true
+
+[dependencies.bytes]
+version = "1"
+optional = true
+default-features = false
+
+[dependencies.const-oid]
+version = "0.9.2"
+optional = true
+
+[dependencies.der_derive]
+version = "0.7.2"
+optional = true
+
+[dependencies.flagset]
+version = "0.4.3"
+optional = true
+
+[dependencies.pem-rfc7468]
+version = "0.7"
+features = ["alloc"]
+optional = true
+
+[dependencies.time]
+version = "0.3.4"
+optional = true
+default-features = false
+
+[dependencies.zeroize]
+version = "1.5"
+optional = true
+default-features = false
+
+[dev-dependencies.hex-literal]
+version = "0.3.0"
+
+[dev-dependencies.proptest]
+version = "1"
+
+[features]
+alloc = ["zeroize?/alloc"]
+arbitrary = [
+ "dep:arbitrary",
+ "const-oid?/arbitrary",
+ "std",
+]
+bytes = [
+ "dep:bytes",
+ "alloc",
+]
+derive = ["dep:der_derive"]
+oid = ["dep:const-oid"]
+pem = [
+ "dep:pem-rfc7468",
+ "alloc",
+ "zeroize",
+]
+real = []
+std = ["alloc"]