summaryrefslogtreecommitdiffstats
path: root/vendor/ecdsa/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/ecdsa/Cargo.toml')
-rw-r--r--vendor/ecdsa/Cargo.toml148
1 files changed, 148 insertions, 0 deletions
diff --git a/vendor/ecdsa/Cargo.toml b/vendor/ecdsa/Cargo.toml
new file mode 100644
index 0000000..9e2678d
--- /dev/null
+++ b/vendor/ecdsa/Cargo.toml
@@ -0,0 +1,148 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.65"
+name = "ecdsa"
+version = "0.16.8"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust implementation of the Elliptic Curve Digital Signature Algorithm
+(ECDSA) as specified in FIPS 186-4 (Digital Signature Standard), providing
+RFC6979 deterministic signatures as well as support for added entropy
+"""
+readme = "README.md"
+keywords = [
+ "crypto",
+ "ecc",
+ "nist",
+ "secp256k1",
+ "signature",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/signatures/tree/master/ecdsa"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.der]
+version = "0.7"
+optional = true
+
+[dependencies.digest]
+version = "0.10.7"
+features = ["oid"]
+optional = true
+default-features = false
+
+[dependencies.elliptic-curve]
+version = "0.13.5"
+features = [
+ "digest",
+ "sec1",
+]
+default-features = false
+
+[dependencies.rfc6979]
+version = "0.4"
+optional = true
+
+[dependencies.serdect]
+version = "0.2"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dependencies.sha2]
+version = "0.10"
+features = ["oid"]
+optional = true
+default-features = false
+
+[dependencies.signature]
+version = "2.1"
+features = ["rand_core"]
+default-features = false
+
+[dependencies.spki]
+version = "0.7.2"
+optional = true
+default-features = false
+
+[dev-dependencies.elliptic-curve]
+version = "0.13"
+features = ["dev"]
+default-features = false
+
+[dev-dependencies.hex-literal]
+version = "0.4"
+
+[dev-dependencies.sha2]
+version = "0.10"
+default-features = false
+
+[features]
+alloc = [
+ "elliptic-curve/alloc",
+ "signature/alloc",
+ "spki/alloc",
+]
+arithmetic = ["elliptic-curve/arithmetic"]
+default = ["digest"]
+dev = [
+ "arithmetic",
+ "digest",
+ "elliptic-curve/dev",
+ "hazmat",
+]
+digest = [
+ "dep:digest",
+ "signature/digest",
+]
+hazmat = []
+pem = [
+ "elliptic-curve/pem",
+ "pkcs8",
+]
+pkcs8 = [
+ "digest",
+ "elliptic-curve/pkcs8",
+ "der",
+]
+serde = [
+ "elliptic-curve/serde",
+ "serdect",
+]
+signing = [
+ "arithmetic",
+ "digest",
+ "hazmat",
+ "rfc6979",
+]
+std = [
+ "alloc",
+ "elliptic-curve/std",
+ "signature/std",
+]
+verifying = [
+ "arithmetic",
+ "digest",
+ "hazmat",
+]