summaryrefslogtreecommitdiffstats
path: root/vendor/env_logger/debian/patches/eliminate-is-terminal.patch
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/env_logger/debian/patches/eliminate-is-terminal.patch')
-rw-r--r--vendor/env_logger/debian/patches/eliminate-is-terminal.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/vendor/env_logger/debian/patches/eliminate-is-terminal.patch b/vendor/env_logger/debian/patches/eliminate-is-terminal.patch
new file mode 100644
index 0000000..d402b90
--- /dev/null
+++ b/vendor/env_logger/debian/patches/eliminate-is-terminal.patch
@@ -0,0 +1,36 @@
+Index: env-logger/Cargo.toml
+===================================================================
+--- env-logger.orig/Cargo.toml
++++ env-logger/Cargo.toml
+@@ -93,10 +93,6 @@ harness = false
+ version = "2.0.0"
+ optional = true
+
+-[dependencies.is-terminal]
+-version = "0.4.0"
+-optional = true
+-
+ [dependencies.log]
+ version = "0.4.8"
+ features = ["std"]
+@@ -116,7 +112,6 @@ optional = true
+
+ [features]
+ auto-color = [
+- "dep:is-terminal",
+ "color",
+ ]
+ color = ["dep:termcolor"]
+Index: env-logger/src/fmt/writer/atty.rs
+===================================================================
+--- env-logger.orig/src/fmt/writer/atty.rs
++++ env-logger/src/fmt/writer/atty.rs
+@@ -8,7 +8,7 @@ printed.
+
+ #[cfg(feature = "auto-color")]
+ mod imp {
+- use is_terminal::IsTerminal;
++ use std::io::IsTerminal;
+
+ pub(in crate::fmt) fn is_stdout() -> bool {
+ std::io::stdout().is_terminal()