summaryrefslogtreecommitdiffstats
path: root/vendor/fastrand/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/fastrand/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/vendor/fastrand/Cargo.toml b/vendor/fastrand/Cargo.toml
new file mode 100644
index 0000000..d3c55d1
--- /dev/null
+++ b/vendor/fastrand/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.36"
+name = "fastrand"
+version = "2.0.1"
+authors = ["Stjepan Glavina <stjepang@gmail.com>"]
+exclude = ["/.*"]
+description = "A simple and fast random number generator"
+readme = "README.md"
+keywords = [
+ "simple",
+ "fast",
+ "rand",
+ "random",
+ "wyrand",
+]
+categories = ["algorithms"]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/smol-rs/fastrand"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dev-dependencies.getrandom]
+version = "0.2"
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[dev-dependencies.wyhash]
+version = "0.5"
+
+[features]
+alloc = []
+default = ["std"]
+# js = [
+# "std",
+# "getrandom",
+# ]
+std = ["alloc"]