summaryrefslogtreecommitdiffstats
path: root/vendor/fwdansi
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/fwdansi')
-rw-r--r--vendor/fwdansi/.cargo-checksum.json1
-rw-r--r--vendor/fwdansi/Cargo.lock419
-rw-r--r--vendor/fwdansi/Cargo.toml36
-rw-r--r--vendor/fwdansi/appveyor.yml20
-rw-r--r--vendor/fwdansi/examples/colors.rs22
-rw-r--r--vendor/fwdansi/examples/run-rustc.rs17
-rw-r--r--vendor/fwdansi/rustfmt.toml1
-rw-r--r--vendor/fwdansi/src/lib.rs234
-rw-r--r--vendor/fwdansi/tests/tests.proptest-regressions11
-rw-r--r--vendor/fwdansi/tests/tests.rs97
10 files changed, 858 insertions, 0 deletions
diff --git a/vendor/fwdansi/.cargo-checksum.json b/vendor/fwdansi/.cargo-checksum.json
new file mode 100644
index 0000000..0ff4375
--- /dev/null
+++ b/vendor/fwdansi/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{},"package":"08c1f5787fe85505d1f7777268db5103d80a7a374d2316a7ce262e57baf8f208"} \ No newline at end of file
diff --git a/vendor/fwdansi/Cargo.lock b/vendor/fwdansi/Cargo.lock
new file mode 100644
index 0000000..bcd6504
--- /dev/null
+++ b/vendor/fwdansi/Cargo.lock
@@ -0,0 +1,419 @@
+# This file is automatically @generated by Cargo.
+# It is not intended for manual editing.
+[[package]]
+name = "autocfg"
+version = "0.1.7"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "bit-set"
+version = "0.5.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "bit-vec 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "bit-vec"
+version = "0.5.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "bitflags"
+version = "1.2.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "byteorder"
+version = "1.3.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "c2-chacha"
+version = "0.2.3"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "ppv-lite86 0.2.6 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "cfg-if"
+version = "0.1.10"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "cloudabi"
+version = "0.0.3"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "bitflags 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "fnv"
+version = "1.0.6"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "fuchsia-cprng"
+version = "0.1.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "fwdansi"
+version = "1.1.0"
+dependencies = [
+ "memchr 2.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "proptest 0.9.4 (registry+https://github.com/rust-lang/crates.io-index)",
+ "termcolor 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "getrandom"
+version = "0.1.13"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "cfg-if 0.1.10 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.65 (registry+https://github.com/rust-lang/crates.io-index)",
+ "wasi 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "lazy_static"
+version = "1.4.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "libc"
+version = "0.2.65"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "memchr"
+version = "2.2.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "num-traits"
+version = "0.2.9"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "autocfg 0.1.7 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "ppv-lite86"
+version = "0.2.6"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "proptest"
+version = "0.9.4"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "bit-set 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "bitflags 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "byteorder 1.3.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "num-traits 0.2.9 (registry+https://github.com/rust-lang/crates.io-index)",
+ "quick-error 1.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand 0.6.5 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_chacha 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_xorshift 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "regex-syntax 0.6.12 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rusty-fork 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "tempfile 3.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "quick-error"
+version = "1.2.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "rand"
+version = "0.6.5"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "autocfg 0.1.7 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.65 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_chacha 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_core 0.4.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_hc 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_isaac 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_jitter 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_os 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_pcg 0.1.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_xorshift 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "winapi 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand"
+version = "0.7.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "getrandom 0.1.13 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.65 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_chacha 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_core 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_hc 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand_chacha"
+version = "0.1.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "autocfg 0.1.7 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_core 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand_chacha"
+version = "0.2.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "c2-chacha 0.2.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_core 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand_core"
+version = "0.3.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "rand_core 0.4.2 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand_core"
+version = "0.4.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "rand_core"
+version = "0.5.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "getrandom 0.1.13 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand_hc"
+version = "0.1.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "rand_core 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand_hc"
+version = "0.2.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "rand_core 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand_isaac"
+version = "0.1.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "rand_core 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand_jitter"
+version = "0.1.4"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "libc 0.2.65 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_core 0.4.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "winapi 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand_os"
+version = "0.1.3"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "cloudabi 0.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "fuchsia-cprng 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.65 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_core 0.4.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rdrand 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "winapi 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand_pcg"
+version = "0.1.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "autocfg 0.1.7 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand_core 0.4.2 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rand_xorshift"
+version = "0.1.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "rand_core 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rdrand"
+version = "0.4.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "rand_core 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "redox_syscall"
+version = "0.1.56"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "regex-syntax"
+version = "0.6.12"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "remove_dir_all"
+version = "0.5.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "winapi 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "rusty-fork"
+version = "0.2.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)",
+ "quick-error 1.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "tempfile 3.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "wait-timeout 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "tempfile"
+version = "3.1.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "cfg-if 0.1.10 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.65 (registry+https://github.com/rust-lang/crates.io-index)",
+ "rand 0.7.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "redox_syscall 0.1.56 (registry+https://github.com/rust-lang/crates.io-index)",
+ "remove_dir_all 0.5.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "winapi 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "termcolor"
+version = "1.0.5"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "wincolor 1.0.2 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "wait-timeout"
+version = "0.2.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "libc 0.2.65 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "wasi"
+version = "0.7.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "winapi"
+version = "0.3.8"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "winapi-i686-pc-windows-gnu 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "winapi-x86_64-pc-windows-gnu 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "winapi-i686-pc-windows-gnu"
+version = "0.4.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "winapi-util"
+version = "0.1.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "winapi 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[[package]]
+name = "winapi-x86_64-pc-windows-gnu"
+version = "0.4.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+
+[[package]]
+name = "wincolor"
+version = "1.0.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+dependencies = [
+ "winapi 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
+ "winapi-util 0.1.2 (registry+https://github.com/rust-lang/crates.io-index)",
+]
+
+[metadata]
+"checksum autocfg 0.1.7 (registry+https://github.com/rust-lang/crates.io-index)" = "1d49d90015b3c36167a20fe2810c5cd875ad504b39cff3d4eae7977e6b7c1cb2"
+"checksum bit-set 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)" = "e84c238982c4b1e1ee668d136c510c67a13465279c0cb367ea6baf6310620a80"
+"checksum bit-vec 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)" = "f59bbe95d4e52a6398ec21238d31577f2b28a9d86807f06ca59d191d8440d0bb"
+"checksum bitflags 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)" = "cf1de2fe8c75bc145a2f577add951f8134889b4795d47466a54a5c846d691693"
+"checksum byteorder 1.3.2 (registry+https://github.com/rust-lang/crates.io-index)" = "a7c3dd8985a7111efc5c80b44e23ecdd8c007de8ade3b96595387e812b957cf5"
+"checksum c2-chacha 0.2.3 (registry+https://github.com/rust-lang/crates.io-index)" = "214238caa1bf3a496ec3392968969cab8549f96ff30652c9e56885329315f6bb"
+"checksum cfg-if 0.1.10 (registry+https://github.com/rust-lang/crates.io-index)" = "4785bdd1c96b2a846b2bd7cc02e86b6b3dbf14e7e53446c4f54c92a361040822"
+"checksum cloudabi 0.0.3 (registry+https://github.com/rust-lang/crates.io-index)" = "ddfc5b9aa5d4507acaf872de71051dfd0e309860e88966e1051e462a077aac4f"
+"checksum fnv 1.0.6 (registry+https://github.com/rust-lang/crates.io-index)" = "2fad85553e09a6f881f739c29f0b00b0f01357c743266d478b68951ce23285f3"
+"checksum fuchsia-cprng 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)" = "a06f77d526c1a601b7c4cdd98f54b5eaabffc14d5f2f0296febdc7f357c6d3ba"
+"checksum getrandom 0.1.13 (registry+https://github.com/rust-lang/crates.io-index)" = "e7db7ca94ed4cd01190ceee0d8a8052f08a247aa1b469a7f68c6a3b71afcf407"
+"checksum lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "e2abad23fbc42b3700f2f279844dc832adb2b2eb069b2df918f455c4e18cc646"
+"checksum libc 0.2.65 (registry+https://github.com/rust-lang/crates.io-index)" = "1a31a0627fdf1f6a39ec0dd577e101440b7db22672c0901fe00a9a6fbb5c24e8"
+"checksum memchr 2.2.1 (registry+https://github.com/rust-lang/crates.io-index)" = "88579771288728879b57485cc7d6b07d648c9f0141eb955f8ab7f9d45394468e"
+"checksum num-traits 0.2.9 (registry+https://github.com/rust-lang/crates.io-index)" = "443c53b3c3531dfcbfa499d8893944db78474ad7a1d87fa2d94d1a2231693ac6"
+"checksum ppv-lite86 0.2.6 (registry+https://github.com/rust-lang/crates.io-index)" = "74490b50b9fbe561ac330df47c08f3f33073d2d00c150f719147d7c54522fa1b"
+"checksum proptest 0.9.4 (registry+https://github.com/rust-lang/crates.io-index)" = "cf147e022eacf0c8a054ab864914a7602618adba841d800a9a9868a5237a529f"
+"checksum quick-error 1.2.2 (registry+https://github.com/rust-lang/crates.io-index)" = "9274b940887ce9addde99c4eee6b5c44cc494b182b97e73dc8ffdcb3397fd3f0"
+"checksum rand 0.6.5 (registry+https://github.com/rust-lang/crates.io-index)" = "6d71dacdc3c88c1fde3885a3be3fbab9f35724e6ce99467f7d9c5026132184ca"
+"checksum rand 0.7.2 (registry+https://github.com/rust-lang/crates.io-index)" = "3ae1b169243eaf61759b8475a998f0a385e42042370f3a7dbaf35246eacc8412"
+"checksum rand_chacha 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)" = "556d3a1ca6600bfcbab7c7c91ccb085ac7fbbcd70e008a98742e7847f4f7bcef"
+"checksum rand_chacha 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)" = "03a2a90da8c7523f554344f921aa97283eadf6ac484a6d2a7d0212fa7f8d6853"
+"checksum rand_core 0.3.1 (registry+https://github.com/rust-lang/crates.io-index)" = "7a6fdeb83b075e8266dcc8762c22776f6877a63111121f5f8c7411e5be7eed4b"
+"checksum rand_core 0.4.2 (registry+https://github.com/rust-lang/crates.io-index)" = "9c33a3c44ca05fa6f1807d8e6743f3824e8509beca625669633be0acbdf509dc"
+"checksum rand_core 0.5.1 (registry+https://github.com/rust-lang/crates.io-index)" = "90bde5296fc891b0cef12a6d03ddccc162ce7b2aff54160af9338f8d40df6d19"
+"checksum rand_hc 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)" = "7b40677c7be09ae76218dc623efbf7b18e34bced3f38883af07bb75630a21bc4"
+"checksum rand_hc 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)" = "ca3129af7b92a17112d59ad498c6f81eaf463253766b90396d39ea7a39d6613c"
+"checksum rand_isaac 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)" = "ded997c9d5f13925be2a6fd7e66bf1872597f759fd9dd93513dd7e92e5a5ee08"
+"checksum rand_jitter 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)" = "1166d5c91dc97b88d1decc3285bb0a99ed84b05cfd0bc2341bdf2d43fc41e39b"
+"checksum rand_os 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)" = "7b75f676a1e053fc562eafbb47838d67c84801e38fc1ba459e8f180deabd5071"
+"checksum rand_pcg 0.1.2 (registry+https://github.com/rust-lang/crates.io-index)" = "abf9b09b01790cfe0364f52bf32995ea3c39f4d2dd011eac241d2914146d0b44"
+"checksum rand_xorshift 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)" = "cbf7e9e623549b0e21f6e97cf8ecf247c1a8fd2e8a992ae265314300b2455d5c"
+"checksum rdrand 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "678054eb77286b51581ba43620cc911abf02758c91f93f479767aed0f90458b2"
+"checksum redox_syscall 0.1.56 (registry+https://github.com/rust-lang/crates.io-index)" = "2439c63f3f6139d1b57529d16bc3b8bb855230c8efcc5d3a896c8bea7c3b1e84"
+"checksum regex-syntax 0.6.12 (registry+https://github.com/rust-lang/crates.io-index)" = "11a7e20d1cce64ef2fed88b66d347f88bd9babb82845b2b858f3edbf59a4f716"
+"checksum remove_dir_all 0.5.2 (registry+https://github.com/rust-lang/crates.io-index)" = "4a83fa3702a688b9359eccba92d153ac33fd2e8462f9e0e3fdf155239ea7792e"
+"checksum rusty-fork 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)" = "3dd93264e10c577503e926bd1430193eeb5d21b059148910082245309b424fae"
+"checksum tempfile 3.1.0 (registry+https://github.com/rust-lang/crates.io-index)" = "7a6e24d9338a0a5be79593e2fa15a648add6138caa803e2d5bc782c371732ca9"
+"checksum termcolor 1.0.5 (registry+https://github.com/rust-lang/crates.io-index)" = "96d6098003bde162e4277c70665bd87c326f5a0c3f3fbfb285787fa482d54e6e"
+"checksum wait-timeout 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)" = "9f200f5b12eb75f8c1ed65abd4b2db8a6e1b138a20de009dacee265a2498f3f6"
+"checksum wasi 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)" = "b89c3ce4ce14bdc6fb6beaf9ec7928ca331de5df7e5ea278375642a2f478570d"
+"checksum winapi 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)" = "8093091eeb260906a183e6ae1abdba2ef5ef2257a21801128899c3fc699229c6"
+"checksum winapi-i686-pc-windows-gnu 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "ac3b87c63620426dd9b991e5ce0329eff545bccbbb34f3be09ff6fb6ab51b7b6"
+"checksum winapi-util 0.1.2 (registry+https://github.com/rust-lang/crates.io-index)" = "7168bab6e1daee33b4557efd0e95d5ca70a03706d39fa5f3fe7a236f584b03c9"
+"checksum winapi-x86_64-pc-windows-gnu 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f"
+"checksum wincolor 1.0.2 (registry+https://github.com/rust-lang/crates.io-index)" = "96f5016b18804d24db43cebf3c77269e7569b8954a8464501c216cc5e070eaa9"
diff --git a/vendor/fwdansi/Cargo.toml b/vendor/fwdansi/Cargo.toml
new file mode 100644
index 0000000..c317662
--- /dev/null
+++ b/vendor/fwdansi/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "fwdansi"
+version = "1.1.0"
+authors = ["kennytm <kennytm@gmail.com>"]
+description = "Forwards a byte string with ANSI escape code to a termcolor terminal"
+keywords = ["ansi", "windows", "console", "terminal", "color"]
+categories = ["command-line-interface"]
+license = "MIT"
+repository = "https://github.com/kennytm/fwdansi"
+[dependencies.memchr]
+version = "2"
+
+[dependencies.termcolor]
+version = "1"
+[dev-dependencies.proptest]
+version = "0.9"
+[badges.appveyor]
+repository = "kennytm/fwdansi"
+
+[badges.maintenance]
+status = "passively-maintained"
+
+[badges.travis-ci]
+repository = "kennytm/fwdansi"
diff --git a/vendor/fwdansi/appveyor.yml b/vendor/fwdansi/appveyor.yml
new file mode 100644
index 0000000..076021a
--- /dev/null
+++ b/vendor/fwdansi/appveyor.yml
@@ -0,0 +1,20 @@
+environment:
+ matrix:
+ - TOOLCHAIN: 1.32.0
+ - TOOLCHAIN: stable
+ - TOOLCHAIN: beta
+ - TOOLCHAIN: nightly
+
+install:
+ - appveyor DownloadFile https://win.rustup.rs/x86_64 -FileName rustup-init.exe
+ - rustup-init -y --default-toolchain %TOOLCHAIN%
+ - SET PATH=%PATH%;C:\Users\appveyor\.cargo\bin
+ - rustc -vV
+ - cargo -vV
+
+test_script:
+ - cargo build
+ - cargo test
+ - cargo run --example run-rustc
+
+build: false
diff --git a/vendor/fwdansi/examples/colors.rs b/vendor/fwdansi/examples/colors.rs
new file mode 100644
index 0000000..28ae65b
--- /dev/null
+++ b/vendor/fwdansi/examples/colors.rs
@@ -0,0 +1,22 @@
+extern crate fwdansi;
+extern crate termcolor;
+
+use fwdansi::write_ansi;
+use std::io;
+use termcolor::*;
+
+fn main() -> io::Result<()> {
+ let mut stdout = StandardStream::stdout(ColorChoice::Always);
+
+ for fg in (30..=37).chain(90..=97) {
+ for bg in (40..=47).chain(100..=107) {
+ write_ansi(
+ &mut stdout,
+ format!("<\u{1b}[{fg};{bg}m{fg:2},{bg:3}\u{1b}[0m>", fg = fg, bg = bg).as_bytes(),
+ )?;
+ }
+ write_ansi(&mut stdout, b"\n")?;
+ }
+
+ Ok(())
+}
diff --git a/vendor/fwdansi/examples/run-rustc.rs b/vendor/fwdansi/examples/run-rustc.rs
new file mode 100644
index 0000000..7951601
--- /dev/null
+++ b/vendor/fwdansi/examples/run-rustc.rs
@@ -0,0 +1,17 @@
+extern crate fwdansi;
+extern crate termcolor;
+
+use fwdansi::write_ansi;
+use std::io;
+use std::process::Command;
+use termcolor::*;
+
+fn main() -> io::Result<()> {
+ let output = Command::new("rustc").args(&["--color", "always"]).output()?;
+
+ let mut stderr = StandardStream::stderr(ColorChoice::Always);
+ write_ansi(&mut stderr, &output.stderr)?;
+ //^ should print "error: no input filename given" with appropriate color everywhere.
+
+ Ok(())
+}
diff --git a/vendor/fwdansi/rustfmt.toml b/vendor/fwdansi/rustfmt.toml
new file mode 100644
index 0000000..7530651
--- /dev/null
+++ b/vendor/fwdansi/rustfmt.toml
@@ -0,0 +1 @@
+max_width = 120
diff --git a/vendor/fwdansi/src/lib.rs b/vendor/fwdansi/src/lib.rs
new file mode 100644
index 0000000..45638c9
--- /dev/null
+++ b/vendor/fwdansi/src/lib.rs
@@ -0,0 +1,234 @@
+//! Write colored strings with ANSI escape code into a `termcolor` terminal.
+//!
+//! This package provides a single function, [`write_ansi`], which parses ANSI
+//! escape codes in the provided byte string and transforms them into the
+//! corresponding `termcolor` commands. The colors will be supported even on a
+//! Windows console.
+//!
+//! The main purpose of this package is to forward colored output from a child
+//! process.
+//!
+//! ```rust
+// #![doc(include = "../examples/rustc.rs")] // still unstable, see issue 44732
+//! extern crate termcolor;
+//! extern crate fwdansi;
+//!
+//! use termcolor::*;
+//! use std::io;
+//! use std::process::Command;
+//! use fwdansi::write_ansi;
+//!
+//! fn main() -> io::Result<()> {
+//! let output = Command::new("rustc").args(&["--color", "always"]).output()?;
+//!
+//! let mut stderr = StandardStream::stderr(ColorChoice::Always);
+//! write_ansi(&mut stderr, &output.stderr)?;
+//! //^ should print "error: no input filename given" with appropriate color everywhere.
+//!
+//! Ok(())
+//! }
+//! ```
+
+extern crate memchr;
+extern crate termcolor;
+
+use memchr::memchr;
+use termcolor::{Color, ColorSpec, WriteColor};
+
+use std::io;
+
+/// Writes a string with ANSI escape code into the colored output stream.
+///
+/// Only SGR (`\x1b[…m`) is supported. Other input will be printed as-is.
+pub fn write_ansi<W: WriteColor>(mut writer: W, mut ansi: &[u8]) -> io::Result<()> {
+ while let Some(index) = memchr(0x1b, ansi) {
+ let (left, right) = ansi.split_at(index);
+ writer.write_all(left)?;
+ if right.is_empty() {
+ return Ok(());
+ }
+
+ let mut parser = ColorSpecParser::new(right);
+ parser.parse();
+ if parser.ansi.as_ptr() == right.as_ptr() {
+ writer.write_all(&right[..1])?;
+ ansi = &right[1..];
+ } else {
+ if parser.reset {
+ writer.reset()?;
+ } else {
+ writer.set_color(&parser.spec)?;
+ }
+ ansi = parser.ansi;
+ }
+ }
+ writer.write_all(ansi)
+}
+
+#[derive(Copy, Clone, PartialEq, Eq, Debug)]
+enum State {
+ Normal,
+ PrepareCustomColor,
+ Ansi256,
+ Rgb,
+}
+#[derive(Debug)]
+struct ColorSpecParser<'a> {
+ spec: ColorSpec,
+ ansi: &'a [u8],
+ reset: bool,
+ state: State,
+ is_bg: bool,
+ red: Option<u8>,
+ green: Option<u8>,
+}
+impl<'a> ColorSpecParser<'a> {
+ fn new(ansi: &'a [u8]) -> Self {
+ Self {
+ spec: ColorSpec::new(),
+ ansi,
+ reset: false,
+ state: State::Normal,
+ is_bg: false,
+ red: None,
+ green: None,
+ }
+ }
+
+ fn parse(&mut self) {
+ #[derive(PartialEq, Eq, Debug)]
+ enum Expected {
+ Escape,
+ OpenBracket,
+ Number(u8),
+ }
+
+ while !self.ansi.is_empty() {
+ let mut expected = Expected::Escape;
+ let mut it = self.ansi.iter();
+ for b in &mut it {
+ match (*b, expected) {
+ (0x1b, Expected::Escape) => {
+ expected = Expected::OpenBracket;
+ continue;
+ }
+ (b'[', Expected::OpenBracket) => {
+ expected = Expected::Number(0);
+ continue;
+ }
+ (b'0'..=b'9', Expected::Number(number)) => {
+ if let Some(n) = number.checked_mul(10).and_then(|n| n.checked_add(b - b'0')) {
+ expected = Expected::Number(n);
+ continue;
+ }
+ }
+ (b':', Expected::Number(number))
+ | (b';', Expected::Number(number))
+ | (b'm', Expected::Number(number)) => {
+ self.apply_number(number);
+ if *b == b'm' {
+ expected = Expected::Escape;
+ break;
+ } else {
+ expected = Expected::Number(0);
+ continue;
+ }
+ }
+ _ => {}
+ }
+ return;
+ }
+ if let Expected::Escape = expected {
+ self.ansi = it.as_slice();
+ } else {
+ break;
+ }
+ }
+ }
+
+ fn set_color(&mut self, color: Color) {
+ if self.is_bg {
+ self.spec.set_bg(Some(color));
+ } else {
+ self.spec.set_fg(Some(color));
+ }
+ }
+
+ fn apply_number(&mut self, number: u8) {
+ self.reset = false;
+ match (number, self.state) {
+ (0, State::Normal) => {
+ self.reset = true;
+ }
+ (1, State::Normal) => {
+ self.spec.set_bold(true);
+ }
+ (4, State::Normal) => {
+ self.spec.set_underline(true);
+ }
+ (21, State::Normal) => {
+ self.spec.set_bold(false);
+ }
+ (24, State::Normal) => {
+ self.spec.set_underline(false);
+ }
+ (38, State::Normal) | (48, State::Normal) => {
+ self.is_bg = number == 48;
+ self.state = State::PrepareCustomColor;
+ }
+ (30..=39, State::Normal) => {
+ self.spec.set_fg(parse_color(number - 30));
+ }
+ (40..=49, State::Normal) => {
+ self.spec.set_bg(parse_color(number - 40));
+ }
+ (90..=97, State::Normal) => {
+ self.spec.set_intense(true).set_fg(parse_color(number - 90));
+ }
+ (100..=107, State::Normal) => {
+ self.spec.set_intense(true).set_bg(parse_color(number - 100));
+ }
+ (5, State::PrepareCustomColor) => {
+ self.state = State::Ansi256;
+ }
+ (2, State::PrepareCustomColor) => {
+ self.state = State::Rgb;
+ self.red = None;
+ self.green = None;
+ }
+ (n, State::Ansi256) => {
+ self.set_color(Color::Ansi256(n));
+ self.state = State::Normal;
+ }
+ (b, State::Rgb) => match (self.red, self.green) {
+ (None, _) => {
+ self.red = Some(b);
+ }
+ (Some(_), None) => {
+ self.green = Some(b);
+ }
+ (Some(r), Some(g)) => {
+ self.set_color(Color::Rgb(r, g, b));
+ self.state = State::Normal;
+ }
+ },
+ _ => {
+ self.state = State::Normal;
+ }
+ }
+ }
+}
+
+fn parse_color(digit: u8) -> Option<Color> {
+ match digit {
+ 0 => Some(Color::Black),
+ 1 => Some(Color::Red),
+ 2 => Some(Color::Green),
+ 3 => Some(Color::Yellow),
+ 4 => Some(Color::Blue),
+ 5 => Some(Color::Magenta),
+ 6 => Some(Color::Cyan),
+ 7 => Some(Color::White),
+ _ => None,
+ }
+}
diff --git a/vendor/fwdansi/tests/tests.proptest-regressions b/vendor/fwdansi/tests/tests.proptest-regressions
new file mode 100644
index 0000000..ad5349d
--- /dev/null
+++ b/vendor/fwdansi/tests/tests.proptest-regressions
@@ -0,0 +1,11 @@
+# Seeds for failure cases proptest has generated in the past. It is
+# automatically read and these particular cases re-run before any
+# novel cases are generated.
+#
+# It is recommended to check this file in to source control so that
+# everyone who runs the test benefits from these saved cases.
+xs 3335351554 386647235 3584534272 266266105 # shrinks to ref elements = [Reset]
+xs 1928044643 2253320966 2424427606 448028530 # shrinks to ref ansi_string = [27]
+xs 1984785545 2043478319 191885995 1442765875 # shrinks to ref elements = [Text([27])]
+xs 4274884889 8924921 2258884976 859679705 # shrinks to ref elements = [Text([27, 91, 109])]
+xs 428132133 722552347 3851126282 1913029940 # shrinks to ref elements = [Text([27, 91, 58])]
diff --git a/vendor/fwdansi/tests/tests.rs b/vendor/fwdansi/tests/tests.rs
new file mode 100644
index 0000000..c82f6f2
--- /dev/null
+++ b/vendor/fwdansi/tests/tests.rs
@@ -0,0 +1,97 @@
+extern crate fwdansi;
+extern crate proptest;
+extern crate termcolor;
+
+use fwdansi::write_ansi;
+use proptest::prelude::*;
+use std::io;
+use termcolor::{Ansi, Color, ColorSpec, WriteColor};
+
+proptest! {
+ #[test]
+ fn check_no_crash(ref ansi_string in any::<Vec<u8>>()) {
+ let mut ansi = Ansi::new(Vec::with_capacity(ansi_string.len()));
+ prop_assert!(write_ansi(&mut ansi, &ansi_string).is_ok());
+ }
+
+ #[test]
+ fn ansi_idempotent(ref elements in prop::collection::vec(Element::any(), 0..100)) {
+ // first, write the test string into an ANSI buffer.
+ let mut original = Ansi::new(Vec::new());
+ for e in elements {
+ e.write(&mut original).unwrap();
+ }
+
+ // recover the original string, and forward it using `write_ansi`.
+ let original = original.into_inner();
+ let mut forwarded = Ansi::new(Vec::with_capacity(original.len()));
+ prop_assert!(write_ansi(&mut forwarded, &original).is_ok());
+ prop_assert_eq!(original, forwarded.into_inner());
+ }
+}
+
+#[derive(Debug, Clone)]
+enum Element {
+ ColorSpec(ColorSpec),
+ Reset,
+ Text(Vec<u8>),
+}
+
+fn any_opt_color() -> impl Strategy<Value = Option<Color>> {
+ let color = prop_oneof![
+ Just(Color::Black),
+ Just(Color::Red),
+ Just(Color::Green),
+ Just(Color::Yellow),
+ Just(Color::Blue),
+ Just(Color::Magenta),
+ Just(Color::Cyan),
+ Just(Color::White),
+ any::<u8>().prop_map(Color::Ansi256),
+ any::<[u8; 3]>().prop_map(|[r, g, b]| Color::Rgb(r, g, b)),
+ ];
+ prop::option::weighted(0.9, color)
+}
+
+prop_compose! {
+ fn any_color_spec()(
+ bold in any::<bool>(),
+ underline in any::<bool>(),
+ intense in any::<bool>(),
+ fg_color in any_opt_color(),
+ bg_color in any_opt_color(),
+ ) -> ColorSpec {
+ let mut spec = ColorSpec::new();
+ spec.set_bold(bold)
+ .set_underline(underline)
+ .set_intense(intense)
+ .set_fg(fg_color)
+ .set_bg(bg_color);
+ spec
+ }
+}
+
+impl Element {
+ fn any() -> impl Strategy<Value = Self> {
+ prop_oneof![
+ Just(Element::Reset),
+ any_color_spec().prop_map(Element::ColorSpec),
+ any::<Vec<u8>>().prop_filter_map("ignored empty SGR", |v| {
+ if v.windows(3).find(|w| w == b"\x1b[m").is_some() {
+ None
+ } else {
+ Some(Element::Text(v))
+ }
+ }),
+ ]
+ }
+
+ fn write<W: WriteColor>(&self, mut w: W) -> io::Result<()> {
+ w.write_all(b"~")?;
+ match self {
+ Element::ColorSpec(cs) => w.set_color(cs),
+ Element::Reset => w.reset(),
+ Element::Text(text) => w.write_all(text),
+ }
+ }
+}