summaryrefslogtreecommitdiffstats
path: root/vendor/git2-curl/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/git2-curl/Cargo.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/vendor/git2-curl/Cargo.toml b/vendor/git2-curl/Cargo.toml
new file mode 100644
index 0000000..f4240e0
--- /dev/null
+++ b/vendor/git2-curl/Cargo.toml
@@ -0,0 +1,58 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "git2-curl"
+version = "0.19.0"
+authors = [
+ "Josh Triplett <josh@joshtriplett.org>",
+ "Alex Crichton <alex@alexcrichton.com>",
+]
+description = """
+Backend for an HTTP transport in libgit2 powered by libcurl.
+
+Intended to be used with the git2 crate.
+"""
+documentation = "https://docs.rs/git2-curl"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/git2-rs"
+
+[[test]]
+name = "all"
+harness = false
+
+[dependencies.curl]
+version = "0.4.33"
+
+[dependencies.git2]
+version = "0.18"
+default-features = false
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.url]
+version = "2.0"
+
+[dev-dependencies.civet]
+version = "0.11"
+
+[dev-dependencies.conduit]
+version = "0.8"
+
+[dev-dependencies.conduit-git-http-backend]
+version = "0.8"
+
+[dev-dependencies.tempfile]
+version = "3.0"
+
+[features]