summaryrefslogtreecommitdiffstats
path: root/vendor/ignore/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/ignore/Cargo.toml')
-rw-r--r--vendor/ignore/Cargo.toml69
1 files changed, 69 insertions, 0 deletions
diff --git a/vendor/ignore/Cargo.toml b/vendor/ignore/Cargo.toml
new file mode 100644
index 0000000..b397dcf
--- /dev/null
+++ b/vendor/ignore/Cargo.toml
@@ -0,0 +1,69 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "ignore"
+version = "0.4.20"
+authors = ["Andrew Gallant <jamslam@gmail.com>"]
+description = """
+A fast library for efficiently matching ignore files such as `.gitignore`
+against file paths.
+"""
+homepage = "https://github.com/BurntSushi/ripgrep/tree/master/crates/ignore"
+documentation = "https://docs.rs/ignore"
+readme = "README.md"
+keywords = [
+ "glob",
+ "ignore",
+ "gitignore",
+ "pattern",
+ "file",
+]
+license = "Unlicense OR MIT"
+repository = "https://github.com/BurntSushi/ripgrep/tree/master/crates/ignore"
+
+[lib]
+name = "ignore"
+bench = false
+
+[dependencies.globset]
+version = "0.4.10"
+
+[dependencies.lazy_static]
+version = "1.1"
+
+[dependencies.log]
+version = "0.4.5"
+
+[dependencies.memchr]
+version = "2.1"
+
+[dependencies.regex]
+version = "1.1"
+
+[dependencies.same-file]
+version = "1.0.4"
+
+[dependencies.thread_local]
+version = "1"
+
+[dependencies.walkdir]
+version = "2.2.7"
+
+[dev-dependencies.crossbeam-channel]
+version = "0.5.0"
+
+[features]
+simd-accel = ["globset/simd-accel"]
+
+[target."cfg(windows)".dependencies.winapi-util]
+version = "0.1.2"