summaryrefslogtreecommitdiffstats
path: root/vendor/linux-raw-sys/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/linux-raw-sys/Cargo.toml')
-rw-r--r--vendor/linux-raw-sys/Cargo.toml87
1 files changed, 87 insertions, 0 deletions
diff --git a/vendor/linux-raw-sys/Cargo.toml b/vendor/linux-raw-sys/Cargo.toml
new file mode 100644
index 0000000..f9f8e70
--- /dev/null
+++ b/vendor/linux-raw-sys/Cargo.toml
@@ -0,0 +1,87 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.63"
+name = "linux-raw-sys"
+version = "0.4.10"
+authors = ["Dan Gohman <dev@sunfishcode.online>"]
+exclude = [
+ "/gen",
+ "/.*",
+]
+description = "Generated bindings for Linux's userspace API"
+documentation = "https://docs.rs/linux-raw-sys"
+readme = "README.md"
+keywords = [
+ "linux",
+ "uapi",
+ "ffi",
+]
+categories = ["external-ffi-bindings"]
+license = "Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT"
+repository = "https://github.com/sunfishcode/linux-raw-sys"
+
+[package.metadata.docs.rs]
+features = [
+ "default",
+ "ioctl",
+ "netlink",
+ "io_uring",
+ "if_ether",
+ "net",
+ "prctl",
+ "elf",
+]
+targets = [
+ "x86_64-unknown-linux-gnu",
+ "i686-unknown-linux-gnu",
+]
+
+[dependencies.compiler_builtins]
+version = "0.1.49"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dev-dependencies.libc]
+version = "0.2.100"
+
+[dev-dependencies.static_assertions]
+version = "1.1.0"
+
+[features]
+default = [
+ "std",
+ "general",
+ "errno",
+]
+elf = []
+errno = []
+general = []
+if_ether = []
+io_uring = []
+ioctl = []
+net = []
+netlink = []
+no_std = []
+prctl = []
+rustc-dep-of-std = [
+ "core",
+ "compiler_builtins",
+ "no_std",
+]
+std = []
+system = []