summaryrefslogtreecommitdiffstats
path: root/vendor/pasetors/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/pasetors/Cargo.toml')
-rw-r--r--vendor/pasetors/Cargo.toml136
1 files changed, 136 insertions, 0 deletions
diff --git a/vendor/pasetors/Cargo.toml b/vendor/pasetors/Cargo.toml
new file mode 100644
index 0000000..8fb7213
--- /dev/null
+++ b/vendor/pasetors/Cargo.toml
@@ -0,0 +1,136 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.65.0"
+name = "pasetors"
+version = "0.6.7"
+authors = ["brycx <brycx@protonmail.com>"]
+description = "PASETO: Platform-Agnostic Security Tokens (in Rust)"
+documentation = "https://docs.rs/pasetors"
+readme = "README.md"
+keywords = [
+ "cryptography",
+ "crypto",
+ "token",
+ "paseto",
+ "authentication",
+]
+categories = [
+ "cryptography",
+ "authentication",
+]
+license = "MIT"
+repository = "https://github.com/brycx/pasetors"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.ct-codecs]
+version = "1.1.1"
+default-features = false
+
+[dependencies.ed25519-compact]
+version = "2.0.2"
+features = ["random"]
+optional = true
+default-features = false
+
+[dependencies.getrandom]
+version = "0.2"
+
+[dependencies.orion]
+version = "0.17.0"
+optional = true
+default-features = false
+
+[dependencies.p384]
+version = "0.13.0"
+optional = true
+
+[dependencies.rand_core]
+version = "0.6.3"
+features = ["getrandom"]
+optional = true
+default-features = false
+
+[dependencies.regex]
+version = "1.5.5"
+optional = true
+
+[dependencies.serde]
+version = "1.0.145"
+optional = true
+
+[dependencies.serde_json]
+version = "1.0.41"
+optional = true
+
+[dependencies.sha2]
+version = "0.10.2"
+optional = true
+
+[dependencies.subtle]
+version = "2.4.1"
+default-features = false
+
+[dependencies.time]
+version = "0.3"
+features = [
+ "parsing",
+ "formatting",
+]
+optional = true
+
+[dependencies.zeroize]
+version = "1.4.1"
+default-features = false
+
+[dev-dependencies.hex]
+version = "0.4.2"
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0.41"
+
+[features]
+default = [
+ "std",
+ "v4",
+ "paserk",
+]
+paserk = ["orion"]
+std = [
+ "serde_json",
+ "time",
+ "regex",
+]
+v2 = [
+ "orion",
+ "ed25519-compact",
+]
+v3 = [
+ "rand_core",
+ "p384",
+ "sha2",
+]
+v4 = [
+ "orion",
+ "ed25519-compact",
+]