summaryrefslogtreecommitdiffstats
path: root/vendor/regex-syntax/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/regex-syntax/Cargo.toml')
-rw-r--r--vendor/regex-syntax/Cargo.toml61
1 files changed, 61 insertions, 0 deletions
diff --git a/vendor/regex-syntax/Cargo.toml b/vendor/regex-syntax/Cargo.toml
new file mode 100644
index 0000000..3602ab3
--- /dev/null
+++ b/vendor/regex-syntax/Cargo.toml
@@ -0,0 +1,61 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.65"
+name = "regex-syntax"
+version = "0.8.2"
+authors = [
+ "The Rust Project Developers",
+ "Andrew Gallant <jamslam@gmail.com>",
+]
+description = "A regular expression parser."
+documentation = "https://docs.rs/regex-syntax"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/regex/tree/master/regex-syntax"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.arbitrary]
+version = "1.3.0"
+features = ["derive"]
+optional = true
+
+[features]
+arbitrary = ["dep:arbitrary"]
+default = [
+ "std",
+ "unicode",
+]
+std = []
+unicode = [
+ "unicode-age",
+ "unicode-bool",
+ "unicode-case",
+ "unicode-gencat",
+ "unicode-perl",
+ "unicode-script",
+ "unicode-segment",
+]
+unicode-age = []
+unicode-bool = []
+unicode-case = []
+unicode-gencat = []
+unicode-perl = []
+unicode-script = []
+unicode-segment = []