summaryrefslogtreecommitdiffstats
path: root/contrib/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:48:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:48:59 +0000
commitd835b2cae8abc71958b69362162e6a70c3d7ef63 (patch)
tree81052e3d2ce3e1bcda085f73d925e9d6257dec15 /contrib/setup.py
parentInitial commit. (diff)
downloadcrmsh-d835b2cae8abc71958b69362162e6a70c3d7ef63.tar.xz
crmsh-d835b2cae8abc71958b69362162e6a70c3d7ef63.zip
Adding upstream version 4.6.0.upstream/4.6.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--contrib/setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/contrib/setup.py b/contrib/setup.py
new file mode 100644
index 0000000..30330b8
--- /dev/null
+++ b/contrib/setup.py
@@ -0,0 +1,33 @@
+#!/usr/bin/python
+
+from __future__ import unicode_literals
+from setuptools import setup
+
+setup(name='pygments-crmsh-lexers',
+ version='0.0.5',
+ description='Pygments crmsh custom lexers.',
+ keywords='pygments crmsh lexer',
+ license='BSD',
+
+ author='Kristoffer Gronlund',
+ author_email='kgronlund@suse.com',
+
+ url='https://github.com/ClusterLabs/crmsh',
+
+ packages=['pygments_crmsh_lexers'],
+ install_requires=['pygments>=2.0.2'],
+
+ entry_points='''[pygments.lexers]
+ ANSIColorsLexer=pygments_crmsh_lexers:ANSIColorsLexer
+ CrmshLexer=pygments_crmsh_lexers:CrmshLexer''',
+
+ classifiers=[
+ 'Environment :: Plugins',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 3',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ],)