summaryrefslogtreecommitdiffstats
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini31
1 files changed, 31 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..e13146e
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,31 @@
+# content of: tox.ini , put in same dir as setup.py
+[tox]
+envlist = py36, py38, py310
+skip_missing_interpreters = true
+
+[base]
+changedir = test/unittests
+deps =
+ pytest
+ pytest-cov
+commands = py.test -vv --cov=crmsh --cov-config .coveragerc --cov-report term --cov-report html {posargs}
+
+[testenv]
+changedir = {[base]changedir}
+deps = {[base]deps}
+commands = {[base]commands}
+
+[testenv:3.6]
+changedir = {[base]changedir}
+deps = {[base]deps}
+commands = {[base]commands}
+
+[testenv:3.8]
+changedir = {[base]changedir}
+deps = {[base]deps}
+commands = {[base]commands}
+
+[testenv:3.10]
+changedir = {[base]changedir}
+deps = {[base]deps}
+commands = {[base]commands}