summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 14:14:45 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 14:14:45 +0000
commit5ee2f2f5960044bdca0a5e1baf77225bdad6409d (patch)
treea1515ac00329374a37113d5d3ea1991f8a5d3c23 /Makefile
parentInitial commit. (diff)
downloadcryptsetup-nuke-password-5ee2f2f5960044bdca0a5e1baf77225bdad6409d.tar.xz
cryptsetup-nuke-password-5ee2f2f5960044bdca0a5e1baf77225bdad6409d.zip
Adding upstream version 4+nmu1.upstream/4+nmu1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..e1d8c0d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,25 @@
+CFLAGS += -Wall -O2
+LDLIBS += -lcrypt
+
+EXECUTABLES = crypt
+
+all: $(EXECUTABLES)
+
+check:
+ ./check
+
+clean:
+ rm -f *.o
+ rm -f $(EXECUTABLES)
+
+install: $(EXECUTABLES)
+ mkdir -p $(DESTDIR)/lib/cryptsetup
+ cp askpass $(DESTDIR)/lib/cryptsetup/
+
+ mkdir -p $(DESTDIR)/usr/share/initramfs-tools/hooks/
+ cp hooks/* $(DESTDIR)/usr/share/initramfs-tools/hooks/
+
+ mkdir -p $(DESTDIR)/usr/lib/cryptsetup-nuke-password
+ cp crypt $(DESTDIR)/usr/lib/cryptsetup-nuke-password/
+
+.PHONY: check clean install