summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 07:58:57 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 07:58:57 +0000
commitbd71bd1b1ea78c8de83e1e559b1379bd90e16803 (patch)
tree08d8763346aa202827d3a7718bb02ae713db69ea /debian/rules
parentAdding upstream version 4.7. (diff)
downloaddav4tbsync-bd71bd1b1ea78c8de83e1e559b1379bd90e16803.tar.xz
dav4tbsync-bd71bd1b1ea78c8de83e1e559b1379bd90e16803.zip
Adding debian version 4.7-1.debian/4.7-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..48d8167
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Uncomment this to turn on verbose mode.
+# export DH_VERBOSE=1
+# export DH_OPTIONS=-v
+
+DAV4TBSYNC_FILES = \
+ _locales \
+ content \
+ skin \
+ background.js \
+ manifest.json \
+ $(NULL)
+
+DAV4TBSYNC_FILES_EXCLUDE = \
+ _locales/Readme.txt \
+ $(NULL)
+
+%:
+ dh $@
+
+override_dh_clean:
+ dh_clean
+ rm -rf debian/build
+
+override_dh_auto_build-indep:
+ mkdir $(CURDIR)/debian/build && \
+ zip --recurse-paths $(CURDIR)/debian/build/dav4tbsync@jobisoft.de.xpi \
+ $(DAV4TBSYNC_FILES) \
+ --exclude $(DAV4TBSYNC_FILES_EXCLUDE)
+ dh_auto_build