summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-09 12:53:54 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-09 12:53:54 +0000
commitec95ed8079eb53a44c1f73152d06dd1af9be4907 (patch)
tree77a78b593d290043fff92f848f4a0a002d75e93f /debian/rules
parentAdding upstream version 13.15.3. (diff)
downloaddebhelper-ec95ed8079eb53a44c1f73152d06dd1af9be4907.tar.xz
debhelper-ec95ed8079eb53a44c1f73152d06dd1af9be4907.zip
Adding debian version 13.15.3.debian/13.15.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4bf5633
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+# If you're looking for an example debian/rules that uses debhelper, see
+# the examples directory.
+#
+# Each debhelper command in this rules file has to be run using ./run,
+# to ensure that the commands and libraries in the source tree are used,
+# rather than the installed ones.
+#
+# We disable autoreconf to avoid build-depending on it (it does
+# nothing for debhelper and it keeps the set of B-D smaller)
+
+ifneq (,$(filter pkg.debhelper.nonls,$(DEB_BUILD_PROFILES)))
+export USE_NLS=no
+endif
+
+PERL ?= perl
+
+%:
+ ./run dh $@ --without autoreconf --with build-stamp
+
+# Disable as they are unneeded (and we can then be sure debhelper
+# builds without needing autotools-dev, dh-strip-nondeterminism etc.)
+override_dh_update_autotools_config override_dh_strip_nondeterminism:
+
+execute_before_dh_install:
+ PERLLIBDIR=$$($(PERL) -MConfig -e 'print $$Config{vendorlib}')/ ; \
+ $(PERL) -I"debian/tmp/$${PERLLIBDIR}" debian/gen-provides > debian/debhelper.substvars