summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:42:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:42:48 +0000
commit897bd5fa16708a48f6fcac881a997a2b6424dc20 (patch)
tree740b9f035c6dde4c28307fcd61dc639e0dec8f51 /Makefile
parentInitial commit. (diff)
downloaddebootstrap-897bd5fa16708a48f6fcac881a997a2b6424dc20.tar.xz
debootstrap-897bd5fa16708a48f6fcac881a997a2b6424dc20.zip
Adding upstream version 1.0.134.upstream/1.0.134
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..21a9a39
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,17 @@
+# avoid dpkg-dev dependency; fish out the version with sed
+VERSION := $(shell sed 's/.*(\(.*\)).*/\1/; q' debian/changelog)
+
+all:
+
+clean:
+
+DSDIR=$(DESTDIR)/usr/share/debootstrap
+install:
+ mkdir -p $(DSDIR)/scripts
+ mkdir -p $(DESTDIR)/usr/sbin
+
+ cp -a scripts/* $(DSDIR)/scripts/
+ install -m 0644 functions $(DSDIR)/
+
+ sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)/usr/sbin/debootstrap
+ chmod 0755 $(DESTDIR)/usr/sbin/debootstrap