summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog22
-rw-r--r--debian/control2
-rw-r--r--debian/salsa-ci.yml6
-rw-r--r--debian/tests/control32
-rwxr-xr-xdebian/tests/debian-testing8
5 files changed, 63 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index dc95d02..17b3e3c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,25 @@
+debootstrap (1.0.135) unstable; urgency=medium
+
+ [ Ken Sharp ]
+ * fix quoting to allow spaces in target directory (Closes: #1061820)
+ * Use distro-info where possible
+ * Remove superfluous symlinks
+ * Use correct keyring and mirror for Ubuntu
+ * Ubuntu: test for dpkg zstd support for Hirsute+
+ * Update dependencies
+ * Remove hardcoded HTTPS mirror and use inline substitution
+
+ [ Adrien Robert ]
+ * fix: handling of DIRECT returned by Acquire::http:Proxy-Auto-Detect
+
+ [ Johannes Schauer Marin Rodrigues ]
+ * debian/tests/debian-testing: test minbase, default and buildd variants
+
+ [ Helmut Grohne ]
+ * make debootstrap work on filesystems mounted nodev (Closes: #1073169)
+
+ -- Luca Boccassi <bluca@debian.org> Sat, 15 Jun 2024 11:13:44 +0100
+
debootstrap (1.0.134-0.0~progress7.99u1) graograman-backports; urgency=medium
* Initial reupload to graograman-backports.
diff --git a/debian/control b/debian/control
index 15767c7..039472c 100644
--- a/debian/control
+++ b/debian/control
@@ -18,7 +18,7 @@ XSBC-Original-Vcs-Git: https://salsa.debian.org/installer-team/debootstrap.git
Package: debootstrap
Architecture: all
Multi-Arch: foreign
-Depends: ${misc:Depends}, wget
+Depends: ${misc:Depends}, wget, distro-info
Recommends: gnupg, mount, ${debootstrap:Recommends}
Suggests: squid-deb-proxy-client, ${debootstrap:Suggests}
Description: Bootstrap a basic Debian system
diff --git a/debian/salsa-ci.yml b/debian/salsa-ci.yml
index 01f9153..f3f84f3 100644
--- a/debian/salsa-ci.yml
+++ b/debian/salsa-ci.yml
@@ -32,8 +32,8 @@ test-unshare:
AUTOPKGTEST_TMP: /tmp
script:
- apt-get update
- - apt-get install --no-install-recommends -y libdistro-info-perl libdpkg-perl libipc-run-perl perl systemd systemd-container ca-certificates mmdebstrap uidmap wget
- - mmdebstrap --variant=custom --mode=unshare --setup-hook=./debian/tests/debian-testing --skip=update,setup,cleanup - "$AUTOPKGTEST_TMP/chroot.d"
+ - apt-get install --no-install-recommends -y libdistro-info-perl libdpkg-perl libipc-run-perl perl systemd systemd-container ca-certificates mmdebstrap uidmap wget distro-info
+ - mmdebstrap --variant=custom --mode=unshare --setup-hook="./debian/tests/debian-testing minbase" --skip=update,setup,cleanup - "$AUTOPKGTEST_TMP/chroot.d"
test-buildd:
stage: test extras
@@ -45,7 +45,7 @@ test-buildd:
- |
set -x
apt-get update
- apt-get install --no-install-recommends -y wget
+ apt-get install --no-install-recommends -y wget distro-info
for SUITE in bullseye bookworm trixie; do
env DEBOOTSTRAP_DIR="$CI_PROJECT_DIR" ./debootstrap --variant=buildd "$SUITE" ./chroot
# check if chroots before trixie are unmerged and chroots of trixie
diff --git a/debian/tests/control b/debian/tests/control
index 27a3a6c..1e38cb1 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,4 +1,5 @@
-Tests: debian-testing
+Features: test-name=debian-testing-minbase
+Test-Command: ./debian/tests/debian-testing minbase
Depends:
debootstrap,
libdistro-info-perl,
@@ -8,6 +9,35 @@ Depends:
systemd [linux-any],
systemd-container [linux-any],
ca-certificates,
+ distro-info,
+Restrictions: allow-stderr, needs-root
+
+Features: test-name=debian-testing-buildd
+Test-Command: ./debian/tests/debian-testing buildd
+Depends:
+ debootstrap,
+ libdistro-info-perl,
+ libdpkg-perl,
+ libipc-run-perl,
+ perl,
+ systemd [linux-any],
+ systemd-container [linux-any],
+ ca-certificates,
+ distro-info,
+Restrictions: allow-stderr, needs-root
+
+Features: test-name=debian-testing-default
+Test-Command: ./debian/tests/debian-testing -
+Depends:
+ debootstrap,
+ libdistro-info-perl,
+ libdpkg-perl,
+ libipc-run-perl,
+ perl,
+ systemd [linux-any],
+ systemd-container [linux-any],
+ ca-certificates,
+ distro-info,
Restrictions: allow-stderr, needs-root
Tests: unsorted-packages-files
diff --git a/debian/tests/debian-testing b/debian/tests/debian-testing
index df94254..126cb82 100755
--- a/debian/tests/debian-testing
+++ b/debian/tests/debian-testing
@@ -16,6 +16,10 @@ use Dpkg::Version;
use IPC::Run qw(run);
use Test::More;
+if (scalar @ARGV != 1) {
+ die "usage: $0 [minbase|-|buildd]"
+}
+my $variant = $ARGV[0];
my $srcdir = getcwd;
sub verbose_run {
@@ -335,7 +339,7 @@ my $testing = $distro_info->testing;
# Should specify multiple components for checking (see Bug#898738)
if (!verbose_run([length($ENV{DEBOOTSTRAP_SCRIPT}) ? $ENV{DEBOOTSTRAP_SCRIPT} : 'debootstrap',
'--include=debootstrap,debian-archive-keyring,gnupg,hello,systemd',
- '--variant=minbase',
+ "--variant=$variant",
'--components=main,contrib,non-free',
$testing, 'chroot.d', $mirror], '>&2')) {
BAIL_OUT("debootstrap failed: $?");
@@ -370,7 +374,7 @@ else {
'--bind-ro=/usr/sbin/debootstrap',
'--bind-ro=/usr/share/debootstrap',
'--',
- 'debootstrap', '--include=hello', '--variant=minbase',
+ 'debootstrap', '--include=hello', "--variant=$variant",
$testing, '/mnt/from-nspawn.d', $mirror], '>&2')) {
BAIL_OUT("debootstrap wrapped in systemd-nspawn failed: $?");
}