summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:05:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:06:11 +0000
commite961d2b77dea9edb50bfe23adeeb0961b99d15c5 (patch)
tree2c324dede967eef2182adba3a0525887133852b4
parentMerging upstream version 0.1.22. (diff)
downloaddebputy-e961d2b77dea9edb50bfe23adeeb0961b99d15c5.tar.xz
debputy-e961d2b77dea9edb50bfe23adeeb0961b99d15c5.zip
Adding debian version 0.1.22.debian/0.1.22
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog39
-rw-r--r--debian/control26
-rw-r--r--debian/tests/control20
3 files changed, 62 insertions, 23 deletions
diff --git a/debian/changelog b/debian/changelog
index 7c26793..f85bf95 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,40 @@
+debputy (0.1.22) unstable; urgency=medium
+
+ [ Niels Thykier ]
+ * migrate-from-dh:
+ - Fix bug where some dh config lines were migrated wrong
+
+ * LSP/Lint:
+ - Provide better "guards" for `debian/rules` and `debputy.manifest`.
+ Since the LSP is accepting generic languages here for compatibility,
+ it should not apply to all instances of those generic languages.
+ - Add basic semantic token and folding range support for comments
+ in deb822 based files.
+ - Detect and leverage trivial cases of `dh ... --with addon` for
+ better precision.
+ - Fix the quick fix handler in LSP mode. It was disabled by mistake
+ due to some refactoring.
+ - Add some basic checks of the changelog sign off dates.
+
+ * CLI Breaking change: Rename `plugable` to `pluggable` in API
+ and command line interface. The relevant API is currently
+ "private-only", which is why this is not listed under a
+ "Plugin API" heading.
+
+ * LSP editor-config: Correct snippet for `vim+ycm`
+ * LSP editor-config emacs: Recommend elpa-markdown-mode
+ * Fix warning about -dbgsym packages for automatic M-A: same
+ * d/control: Add 3.11 version bound on python for now
+ * Improve migration from `dh` related documentation.
+ * Fix bug where `dpkg-gencontrol` could error out on dbgsym packages.
+ Fundamentally the same as debhelper's #1067711.
+
+ [ Otto Kekäläinen ]
+ * Apply 'wrap-and-sort -abkt'
+ * Fix misc spelling errors
+
+ -- Niels Thykier <niels@thykier.net> Wed, 27 Mar 2024 07:42:58 +0100
+
debputy (0.1.21) unstable; urgency=medium
* Plugin API:
@@ -584,8 +621,10 @@ debputy (0.1.7.8) unstable; urgency=medium
* debputy: Provide new `plugable-manifest-rules` topic for `plugin list`.
This subcommand enables the user to get a list of all rules available
under `installations` or `packages.{{PACKAGE}}.transformations`, etc.
+ (Note: it was renamed to `pluggable-manifest-rules` in 0.1.22)
* debputy: Provide a `plugin show plugable-manifest-rules` command that
can provide some details about each rule (such as `install`).
+ (Note: it was renamed to `pluggable-manifest-rules` in 0.1.22)
* MANIFEST-FORMAT.md: Clarify some of the "shell"-like examples.
* MANIFEST-FORMAT.md: Clarify that "install" (with `as`) behaves like
`foo => bar`. Previously, the documentation said `=>` which could also
diff --git a/debian/control b/debian/control
index b393718..603405f 100644
--- a/debian/control
+++ b/debian/control
@@ -5,17 +5,18 @@ Maintainer: Debputy Maintainers <debputy@packages.debian.org>
Uploaders: Niels Thykier <niels@thykier.net>,
Build-Depends: debhelper-compat (= 13),
# man-db <pkg.debputy.ci>,
+ dh-sequence-single-binary,
hunspell-en-us <!nocheck>,
- python3:any,
- python3-colorlog <!pkg.debputy.minimal>,
python3-colored <!pkg.debputy.minimal>,
+ python3-colorlog <!pkg.debputy.minimal>,
python3-debian,
python3-hunspell <!nocheck>,
- python3-pytest <!nocheck>,
python3-lsprotocol <!nocheck>,
+ python3-pytest <!nocheck>,
python3-ruamel.yaml,
- dh-sequence-single-binary,
# debputy-plugin-foo,
+# The code was never checked with an older version than 3.11...
+ python3:any (>= 3.11~),
strip-nondeterminism <!nocheck>,
Rules-Requires-Root: no
Standards-Version: 4.6.2
@@ -27,28 +28,29 @@ Package: dh-debputy
Architecture: all
Depends: debhelper,
man-db <!pkg.debputy.minimal>,
- python3,
+# The code was never checked with an older version than 3.11...
+ python3:any (>= 3.11~),
# The colors dependencies are not necessary for debputy to work.
# However, to have coloring work, we need to use Depends because
# Recommends/Suggests are not resolved for builds and this should
# "just work" for users.
- python3-colorlog <!pkg.debputy.no-color>,
python3-colored <!pkg.debputy.no-color>,
+ python3-colorlog <!pkg.debputy.no-color>,
python3-debian,
python3-ruamel.yaml,
strip-nondeterminism,
Recommends: python3-argcomplete,
Suggests: hunspell-en-us,
- python3-pygls,
- python3-lsprotocol,
python3-hunspell,
-Provides: dh-sequence-debputy (= ${binary:Version}),
+ python3-lsprotocol,
+ python3-pygls,
+Provides: debputy-plugin-gnome,
+ debputy-plugin-numpy3,
+ debputy-plugin-perl-openssl,
+ dh-sequence-debputy (= ${binary:Version}),
dh-sequence-installdebputy (= ${binary:Version}),
dh-sequence-zz-debputy (= ${binary:Version}),
dh-sequence-zz-debputy-rrr (= ${binary:Version}),
- debputy-plugin-gnome,
- debputy-plugin-numpy3,
- debputy-plugin-perl-openssl,
Multi-Arch: foreign
Description: Manifest style Debian-based package builder (debhelper integration)
Package builder that provides a declarative manifest for building Debian-based
diff --git a/debian/tests/control b/debian/tests/control
index 642bb5c..16f64a6 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,19 +1,17 @@
Tests: debputy-py.test
Restrictions: allow-stderr
-Depends:
- @,
- python3-pytest,
- python3-lsprotocol,
- python3-all,
-# debputy loads the library directly for one of the tests.
- libcap2,
+# debputy loads the libcap2 library directly for one of the tests
+Depends: libcap2,
+ python3-all,
+ python3-lsprotocol,
+ python3-pytest,
+ @,
Tests: debputy-cli
Restrictions: allow-stderr, superficial
-Depends: @
+Depends: @,
Tests: debputy-cli-lint-lsp
Restrictions: allow-stderr, superficial
-Depends:
- @,
- python3-lsprotocol,
+Depends: python3-lsprotocol,
+ @,