summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 19:54:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:04:14 +0000
commit04ed2a5ec67fdd72a4113ba7e14968281f5f7312 (patch)
treea3ac1ed1972e7dff14e3f76fa85383b0fc5a3f5e /debian/rules
parentAdding upstream version 0.1.21. (diff)
downloaddebputy-04ed2a5ec67fdd72a4113ba7e14968281f5f7312.tar.xz
debputy-04ed2a5ec67fdd72a4113ba7e14968281f5f7312.zip
Adding debian version 0.1.21.debian/0.1.21
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1221eb2
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+export PERL5LIB=$(CURDIR)/lib
+export PATH:=$(CURDIR):$(PATH)
+export DEBPUTY_CMD=$(CURDIR)/debputy.sh
+
+%:
+ dh $@ --with debputy
+
+override_dh_debputy:
+ dh_debputy --plugin self-hosting-plugins/debputy-self-hosting.json