summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog35
-rwxr-xr-xdebian/rules7
2 files changed, 36 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 2b04cb8..a240198 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,38 @@
+debputy (0.1.45) unstable; urgency=medium
+
+ * Manifest:
+ - Add new `default-build-environment`, `build-environments` and `build-rules`
+ for the new `full` integration mode where `debhelper` is no longer driving
+ the build.
+ - Port all `debhelper` provided build systems to have an native `debputy`
+ counter part with a few tweaks.
+
+
+ * LSP/Lint:
+ - Add `xpm` as a known extension for packager files
+ - Add `Build-Driver` as a known field for `debian/control`.
+ - Add `Files-Excluded` and `Files-Included` as known fields for DEP-5
+ - Quote values in completation items for the manifest. This means that
+ the value for `manifest-version` is now properly YAML quoted.
+
+ * debputy: Remove `--spellcheck` from "random" subcommands
+ * debputy: Fix missing warning with `--debug` (it was supposed to be omitted,
+ but never was due to exception flow).
+ * debputy reformat: Fix bug where orphaned packages would have a style by default
+ * doc: Document decision on plugin module import vs. initialization design
+ * LSP/Lint: Fix crash with certain field being duplicated
+ * MANIFEST-FORMAT.md: Fix wording
+ * Add initial minimal `Build-Driver` support meaning that `debputy` can now use
+ `dpkg-buildpackage`'s new `Build-Driver` support to drive the build without
+ relying on `dh`. This requires bleeding edge features in `dpkg-buildpackage`
+ and `debputy`.
+ * Avoid stacktrace for CTRL + C during `run_command`
+ * Improve error tracking related to plugins
+ * Add remark about `env:` manifest variables sometimes respecting
+ `build-environment`.
+
+ -- Niels Thykier <niels@thykier.net> Sun, 04 Aug 2024 12:37:21 +0000
+
debputy (0.1.44-0.0~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-updates, remaining changes:
diff --git a/debian/rules b/debian/rules
index 1221eb2..424cabe 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,6 @@
#!/usr/bin/make -f
-export PERL5LIB=$(CURDIR)/lib
-export PATH:=$(CURDIR):$(PATH)
export DEBPUTY_CMD=$(CURDIR)/debputy.sh
%:
- dh $@ --with debputy
-
-override_dh_debputy:
- dh_debputy --plugin self-hosting-plugins/debputy-self-hosting.json
+ $(DEBPUTY_CMD) --plugin self-hosting-plugins/debputy-self-hosting.json internal-command dpkg-build-driver-run-task $@