summaryrefslogtreecommitdiffstats
path: root/debian/changelog
diff options
context:
space:
mode:
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ff33f8f..5fa65d8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,37 @@
+debputy (0.1.30) unstable; urgency=medium
+
+ * LSP/Lint:
+ - Detect duplicate separators (commas) in most fields
+ - Fix typo in hover doc for `DM-Upload-Allowed`
+ - Support `X-Style: black` as style declaration to activate
+ automatic reformatting support. Conceptually, this is similar
+ to `wrap-and-sort -satkb` but it may evolve over time.
+ - Support reformatting of field contents on save or via explicit
+ reformat document request from editor (requires that `debputy`
+ knows which style you want - see previous entry for how to do
+ a per-package rule).
+ - Update `emacs+eglot` editor config snippet after the latest
+ elpa-dpkg-dev-el upload.
+
+ * Fix crash bug in embedded python3-debian code
+ * Declare styles for:
+ - Niels Thykier (black)
+ - Chris Hofstaedtler (black)
+
+ * style-prefs.yaml: Adding format rules for several packages
+ * Apply `debian black` style to `d/tests/control`
+ * Fix duplicate stderr logger with LSP (and similar commands)
+ * Fix invalid assertion error in some packages (Closes: #1069362)
+ * Cope better with `python3-colored (<< 2)`
+ Thanks to Chris Hofstaedtler <zeha@debian.org>
+ * Provide a new reformat subcommand. It works like `debputy lint`, but
+ only does formatting (which `debputy lint` does none of).
+ * debputy lint: Fix crash bug on missing `Source` field in `d/control`
+ * debputy: Make `lint` and `check-manifest' quieter to support
+ `pre-commit` hook
+
+ -- Niels Thykier <niels@thykier.net> Sun, 28 Apr 2024 13:21:45 +0000
+
debputy (0.1.29) unstable; urgency=medium
* LSP/Lint: