summaryrefslogtreecommitdiffstats
path: root/pigeonhole/src/plugins/lda-sieve/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pigeonhole/src/plugins/lda-sieve/Makefile.am')
-rw-r--r--pigeonhole/src/plugins/lda-sieve/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/pigeonhole/src/plugins/lda-sieve/Makefile.am b/pigeonhole/src/plugins/lda-sieve/Makefile.am
new file mode 100644
index 0000000..7c2797a
--- /dev/null
+++ b/pigeonhole/src/plugins/lda-sieve/Makefile.am
@@ -0,0 +1,19 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib-sieve \
+ $(LIBDOVECOT_INCLUDE) \
+ $(LIBDOVECOT_DICT_INCLUDE) \
+ $(LIBDOVECOT_SMTP_INCLUDE) \
+ $(LIBDOVECOT_LDA_INCLUDE)
+
+lib90_sieve_plugin_la_LDFLAGS = -module -avoid-version
+
+dovecot_module_LTLIBRARIES = lib90_sieve_plugin.la
+
+lib90_sieve_plugin_la_LIBADD = \
+ $(top_builddir)/src/lib-sieve/libdovecot-sieve.la
+
+lib90_sieve_plugin_la_SOURCES = \
+ lda-sieve-plugin.c
+
+noinst_HEADERS = \
+ lda-sieve-plugin.h