summaryrefslogtreecommitdiffstats
path: root/src/indexer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/indexer/Makefile.am')
-rw-r--r--src/indexer/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/indexer/Makefile.am b/src/indexer/Makefile.am
new file mode 100644
index 0000000..8bfc891
--- /dev/null
+++ b/src/indexer/Makefile.am
@@ -0,0 +1,47 @@
+pkglibexecdir = $(libexecdir)/dovecot
+
+pkglibexec_PROGRAMS = indexer indexer-worker
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-master \
+ -I$(top_srcdir)/src/lib-settings \
+ -I$(top_srcdir)/src/lib-mail \
+ -I$(top_srcdir)/src/lib-index \
+ -I$(top_srcdir)/src/lib-storage \
+ -DPKG_RUNDIR=\""$(rundir)"\" \
+ $(BINARY_CFLAGS)
+
+indexer_LDADD = $(LIBDOVECOT) \
+ $(BINARY_LDFLAGS)
+
+indexer_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+indexer_SOURCES = \
+ indexer.c \
+ indexer-client.c \
+ indexer-queue.c \
+ indexer-settings.c \
+ worker-connection.c \
+ worker-pool.c
+
+indexer_worker_LDADD = \
+ $(LIBDOVECOT_STORAGE) \
+ $(LIBDOVECOT) \
+ $(BINARY_LDFLAGS)
+
+indexer_worker_DEPENDENCIES = \
+ $(LIBDOVECOT_STORAGE_DEPS) \
+ $(LIBDOVECOT_DEPS)
+indexer_worker_SOURCES = \
+ indexer-worker.c \
+ indexer-worker-settings.c \
+ master-connection.c
+
+noinst_HEADERS = \
+ indexer.h \
+ indexer-client.h \
+ indexer-queue.h \
+ master-connection.h \
+ worker-connection.h \
+ worker-pool.h
+