summaryrefslogtreecommitdiffstats
path: root/src/plugins/imap-zlib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/imap-zlib/Makefile.am')
-rw-r--r--src/plugins/imap-zlib/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/plugins/imap-zlib/Makefile.am b/src/plugins/imap-zlib/Makefile.am
new file mode 100644
index 0000000..fa4f2f1
--- /dev/null
+++ b/src/plugins/imap-zlib/Makefile.am
@@ -0,0 +1,25 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-compression \
+ -I$(top_srcdir)/src/lib-mail \
+ -I$(top_srcdir)/src/lib-imap \
+ -I$(top_srcdir)/src/lib-index \
+ -I$(top_srcdir)/src/lib-storage \
+ -I$(top_srcdir)/src/imap
+
+imap_moduledir = $(moduledir)
+
+NOPLUGIN_LDFLAGS =
+lib30_imap_zlib_plugin_la_LDFLAGS = -module -avoid-version
+
+imap_module_LTLIBRARIES = \
+ lib30_imap_zlib_plugin.la
+
+lib30_imap_zlib_plugin_la_LIBADD = \
+ ../../lib-compression/libcompression.la
+
+lib30_imap_zlib_plugin_la_SOURCES = \
+ imap-zlib-plugin.c
+
+noinst_HEADERS = \
+ imap-zlib-plugin.h