summaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am90
1 files changed, 90 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
new file mode 100644
index 0000000..2c7621d
--- /dev/null
+++ b/src/util/Makefile.am
@@ -0,0 +1,90 @@
+pkglibexecdir = $(libexecdir)/dovecot
+
+pkglibexec_PROGRAMS = \
+ rawlog \
+ script \
+ script-login \
+ $(TCPWRAP_BIN) \
+ gdbhelper \
+ maildirlock
+
+noinst_PROGRAMS = \
+ test-fs
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-auth \
+ -I$(top_srcdir)/src/lib-dict \
+ -I$(top_srcdir)/src/lib-fs \
+ -I$(top_srcdir)/src/lib-settings \
+ -I$(top_srcdir)/src/lib-master \
+ -I$(top_srcdir)/src/lib-mail \
+ -I$(top_srcdir)/src/lib-imap \
+ -I$(top_srcdir)/src/lib-index \
+ -I$(top_srcdir)/src/lib-storage \
+ -I$(top_srcdir)/src/auth \
+ -DPKG_LIBEXECDIR=\""$(pkglibexecdir)"\" \
+ -DPKG_RUNDIR=\""$(rundir)"\" \
+ $(BINARY_CFLAGS)
+
+test_fs_SOURCES = test-fs.c
+test_fs_LDADD = $(LIBDOVECOT) \
+ $(BINARY_LDFLAGS)
+test_fs_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+
+rawlog_LDADD = $(LIBDOVECOT) \
+ $(BINARY_LDFLAGS)
+
+rawlog_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+rawlog_SOURCES = \
+ rawlog.c
+
+script_login_LDADD = \
+ $(LIBDOVECOT_STORAGE) \
+ $(LIBDOVECOT) \
+ $(BINARY_LDFLAGS)
+
+script_login_DEPENDENCIES = \
+ $(LIBDOVECOT_STORAGE_DEPS) \
+ $(LIBDOVECOT_DEPS)
+script_login_SOURCES = \
+ script-login.c
+
+script_LDADD = $(LIBDOVECOT) \
+ $(BINARY_LDFLAGS)
+script_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+script_SOURCES = \
+ script.c \
+ health-check-settings.c
+
+if TCPWRAPPERS
+TCPWRAP_BIN = tcpwrap
+tcpwrap_LDADD = $(LIBDOVECOT) $(LIBWRAP_LIBS) \
+ $(BINARY_LDFLAGS)
+
+tcpwrap_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+tcpwrap_SOURCES = \
+ tcpwrap.c \
+ tcpwrap-settings.c
+endif
+
+gdbhelper_LDADD = $(LIBDOVECOT) \
+ $(BINARY_LDFLAGS)
+
+gdbhelper_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+gdbhelper_SOURCES = \
+ gdbhelper.c
+
+maildirlock_LDADD = $(LIBDOVECOT) \
+ $(BINARY_LDFLAGS)
+
+maildirlock_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+maildirlock_SOURCES = \
+ maildirlock.c
+
+pkglibexec_SCRIPTS = health-check.sh
+
+bin_SCRIPTS = dovecot-sysreport
+
+EXTRA_DIST = $(pkglibexec_SCRIPTS) \
+ $(bin_SCRIPTS) \ No newline at end of file