summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:31:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:31:20 +0000
commit73d83372ecc1cfc9458fdfdd4bfc591fbe860bca (patch)
tree7ff966e35d1a7105568b835f5b5a19b87045c558 /Makefile.am
parentAdding upstream version 1.22.7. (diff)
downloaddpkg-73d83372ecc1cfc9458fdfdd4bfc591fbe860bca.tar.xz
dpkg-73d83372ecc1cfc9458fdfdd4bfc591fbe860bca.zip
Adding upstream version 1.22.8.upstream/1.22.8
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 97f4c2b..74f8df1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,7 +124,7 @@ doc-clean:
.PHONY: coverage coverage-clean
if COVERAGE_ENABLED
-LCOV_OPTS = --quiet --rc geninfo_checksum=1 --rc lcov_branch_coverage=1
+LCOV_OPTS = --quiet --rc checksum=1 --rc branch_coverage=1
LCOV_CAPTURE_OPTS = $(LCOV_OPTS) --no-recursion \
--directory $(top_builddir)/lib/dpkg \
--directory $(top_builddir)/src/common \
@@ -157,8 +157,6 @@ coverage: all
$(LCOV) $(LCOV_OPTS) \
--add-tracefile dpkg_base.lcov \
--add-tracefile dpkg_test.lcov \
- --output-file dpkg_merge.lcov
- $(LCOV) $(LCOV_OPTS) --remove dpkg_merge.lcov '/usr/include/*' \
--output-file dpkg.lcov
: # Generate reports
$(LCOV) $(LCOV_OPTS) --list dpkg.lcov