summaryrefslogtreecommitdiffstats
path: root/build-aux/autotest.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:30:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:30:09 +0000
commit3c05da1bdef2a6e2142b4fcac974e7e3fc0db93c (patch)
tree9532e637f47d6ff7246ccbabb62d4e2b4b5908df /build-aux/autotest.am
parentAdding debian version 1.22.6. (diff)
downloaddpkg-3c05da1bdef2a6e2142b4fcac974e7e3fc0db93c.tar.xz
dpkg-3c05da1bdef2a6e2142b4fcac974e7e3fc0db93c.zip
Merging upstream version 1.22.7.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--build-aux/autotest.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/build-aux/autotest.am b/build-aux/autotest.am
index a4bb8ea..19054c5 100644
--- a/build-aux/autotest.am
+++ b/build-aux/autotest.am
@@ -4,6 +4,15 @@ DISTCLEANFILES += at/atconfig
AUTOTEST_DEPS = at/atconfig at/atlocal $(TESTSUITE)
+TEST_VERBOSE ?= 0
+TEST_PARALLEL ?= 1
+
+TEST_VERBOSE_OPT = $(TEST_VERBOSE:0=)
+
+TESTSUITEFLAGS =
+TESTSUITEFLAGS += -j$(TEST_PARALLEL)
+TESTSUITEFLAGS += $(TEST_VERBOSE_OPT:1=--verbose)
+
# The ":;" works around a Bash 3.2 bug when the output is not writable.
$(srcdir)/at/package.m4: $(top_srcdir)/configure.ac
:;{ \