summaryrefslogtreecommitdiffstats
path: root/man/nl/dpkg-buildflags.pod
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:40:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:40:28 +0000
commit774e54c8927088c60617dc9345f55eaabb23256a (patch)
tree7d82ddb667eaec624064c430b57818c78184e3c7 /man/nl/dpkg-buildflags.pod
parentAdding upstream version 1.22.4. (diff)
downloaddpkg-774e54c8927088c60617dc9345f55eaabb23256a.tar.xz
dpkg-774e54c8927088c60617dc9345f55eaabb23256a.zip
Adding upstream version 1.22.5.upstream/1.22.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'man/nl/dpkg-buildflags.pod')
-rw-r--r--man/nl/dpkg-buildflags.pod31
1 files changed, 26 insertions, 5 deletions
diff --git a/man/nl/dpkg-buildflags.pod b/man/nl/dpkg-buildflags.pod
index ce173d7..d2b768a 100644
--- a/man/nl/dpkg-buildflags.pod
+++ b/man/nl/dpkg-buildflags.pod
@@ -180,7 +180,7 @@ Bijvoorbeeld:
=item B<--query-features> I<gebied>
-De functies weergeven die voor een opgegeven gebied geactiveerd zijn (sinds dpkg 1.16.2). Als de functie door de compiler als een ingebouwde standaard wordt behandeld (al is het maar op sommige architecturen), dan wordt een veld B<Builtin> weergegeven (sinds dpkg 1.21.14). Momenteel worden door Debian en zijn derivaten enkel de gebieden B<future>, B<qa>, B<reproducible>, B<sanitize> en B<hardening> herkend. Zie het onderdeel B<FUNCTIEGEBIEDEN> voor meer details. Sluit af met 0 als het gebied gekend is, anders met 1.
+Print the features enabled for a given area (since dpkg 1.16.2). If the feature is handled (even if only on some architectures) as a builtin default by the compiler, then a B<Builtin> field is printed (since dpkg 1.21.14). See the L</FEATURE AREAS> section for more details about the currently recognized areas. Exits with 0 if the area is known otherwise exits with 1.
De uitvoer is in RFC822-indeling met één sectie per functie. Bijvoorbeeld:
@@ -291,13 +291,30 @@ In de toekomst kunnen nog andere vlaggen toegevoegd worden als daar behoefte aan
=head1 FUNCTIEGEBIEDEN
-Elke gebiedsfunctie kan in de gebiedswaarde van de omgevingsvariabelen B<DEB_BUILD_OPTIONS> en B<DEB_BUILD_MAINT_OPTIONS> ingeschakeld en uitgeschakeld worden met de schakelaars ‘B<+>’ en ‘B<->’. Om bijvoorbeeld de B<hardening>-functionaliteit “pie” te activeren en de functionaliteit “fortify” uit te schakelen, kunt u in B<debian/rules> het volgende doen:
+Feature areas are currently vendor specific, and the ones described below are only recognized on Debian and derivatives.
- export DEB_BUILD_MAINT_OPTIONS=hardening=+pie,-fortify
+Each area feature can be enabled and disabled in the B<DEB_BUILD_OPTIONS> and B<DEB_BUILD_MAINT_OPTIONS> environment variable's area value with the ‘B<+>’ and ‘B<->’ modifier. Following the general syntax of these variables (described in L<dpkg-buildpackage(1)>), multiple feature areas can be specified separated by spaces, where each get feature specifiers as mandatory parameters after an equal sign (‘B<=>’). The feature specifiers are comma-separated and parsed from left to right, where the settings within the same feature specifier override previous ones, even if the feature specifiers are split across multiple space-separated feature area settings for the same area.
+
+For example, to enable the B<hardening> “pie” feature and disable the “fortify” feature you can do this in B<debian/rules>:
+
+ export DEB_BUILD_MAINT_OPTIONS = hardening=+pie,-fortify
De bijzondere functie B<all> (geldig in elk gebied) kan gebruikt worden om gelijktijdig alle gebiedsfunctionaliteit te activeren of uit te schakelen. Alles uitschakelen in het gebied B<hardening> en enkel “format” en “fortify” activeren kunt u dus doen met:
- export DEB_BUILD_MAINT_OPTIONS=hardening=-all,+format,+fortify
+ export DEB_BUILD_MAINT_OPTIONS = hardening=-all,+format,+fortify
+
+Multiple feature areas can be set:
+
+ export DEB_BUILD_MAINT_OPTIONS = hardening=+pie abi=+lfs
+
+The override behavior applies as much to the B<all> special feature, as to specific features, which should allow for composition. Thus to enable “lfs” in the B<abi> area, and only “pie” and “fortify” in the B<hardening> area, but “format” only when CONDITION is defined, this could be done with:
+
+ export DEB_BUILD_MAINT_OPTIONS = hardening=-all,+pie,+format abi=+lfs
+ …
+ DEB_BUILD_MAINT_OPTIONS += hardening=+fortify
+ ifdef CONDITION
+ DEB_BUILD_MAINT_OPTIONS += hardening=-format
+ endif
=head2 abi
@@ -313,7 +330,11 @@ Wanneer deze functie is ingeschakeld, wordt de waarde van dezelfde functie in he
=item B<time64>
-Deze instelling (sinds dpkg 1.22.0; standaard uitgezet) activeert ondersteuning voor 64-bits time_t op 32-bits architecturen waar hun ABI dit standaard niet bevat, door B<-D_TIME_BITS=64> toe te voegen aan B<CPPFLAGS>. Deze instelling schakelt automatisch de B<lfs>-functie in aangezien ze deze nodig heeft.
+This setting (since dpkg 1.22.0; enabled by default except for i386, hurd-i386 and kfreebsd-i386 since dpkg 1.22.5) enables 64-bit time_t support on 32-bit architectures where their ABI does not include it by default, by adding B<-D_TIME_BITS=64> to B<CPPFLAGS>. This setting automatically enables the B<lfs> feature from the B<abi> feature area, and the B<bug-implicit-func> feature from the B<qa> feature area as it requires them.
+
+If the setting is enabled explicitly then it gets enabled on all architectures including i386 but not hurd-i386 nor kfreebsd-i386 (where the kernel does not have time64 interfaces), ignoring the binary backwards compatibility default.
+
+It is also enabled by default by gcc on the armel, armhf, hppa, m68k, mips, mipsel, powerpc and sh4 Debian architectures, where disabling the feature will add instead B<-U_LARGEFILE_SOURCE -U_FILE_OFFSET_BITS -U_TIME_BITS> to B<CPPFLAGS>.
=back