summaryrefslogtreecommitdiffstats
path: root/scripts/mk/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /scripts/mk/Makefile.am
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/mk/Makefile.am')
-rw-r--r--scripts/mk/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/scripts/mk/Makefile.am b/scripts/mk/Makefile.am
new file mode 100644
index 0000000..257ba52
--- /dev/null
+++ b/scripts/mk/Makefile.am
@@ -0,0 +1,33 @@
+## Process this file with automake to produce Makefile.in
+
+dist_pkgdata_DATA = \
+ architecture.mk \
+ buildapi.mk \
+ buildflags.mk \
+ buildopts.mk \
+ buildtools.mk \
+ default.mk \
+ pkg-info.mk \
+ vendor.mk \
+ # EOL
+
+SUFFIXES =
+
+include $(top_srcdir)/build-aux/subst.am
+
+# Ideally we'd use '$(SED) -i', but unfortunately that's not portable.
+install-data-hook:
+ $(do_make_subst) <$(DESTDIR)$(pkgdatadir)/default.mk \
+ >$(DESTDIR)$(pkgdatadir)/default.mk.new
+ mv $(DESTDIR)$(pkgdatadir)/default.mk.new \
+ $(DESTDIR)$(pkgdatadir)/default.mk
+
+ $(do_make_subst) <$(DESTDIR)$(pkgdatadir)/buildtools.mk \
+ >$(DESTDIR)$(pkgdatadir)/buildtools.mk.new
+ mv $(DESTDIR)$(pkgdatadir)/buildtools.mk.new \
+ $(DESTDIR)$(pkgdatadir)/buildtools.mk
+
+ $(do_make_subst) <$(DESTDIR)$(pkgdatadir)/vendor.mk \
+ >$(DESTDIR)$(pkgdatadir)/vendor.mk.new
+ mv $(DESTDIR)$(pkgdatadir)/vendor.mk.new \
+ $(DESTDIR)$(pkgdatadir)/vendor.mk