summaryrefslogtreecommitdiffstats
path: root/scripts/mk/buildapi.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:32:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:32:52 +0000
commit3c14ed72233b22898a70db82f4674931b2a717fd (patch)
treef2bf9e8cd0690cc6cb8dd702d0ecf05a26764e71 /scripts/mk/buildapi.mk
parentReleasing progress-linux version 1.22.9-0.0~progress7.99u1. (diff)
downloaddpkg-3c14ed72233b22898a70db82f4674931b2a717fd.tar.xz
dpkg-3c14ed72233b22898a70db82f4674931b2a717fd.zip
Merging upstream version 1.22.10.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--scripts/mk/buildapi.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/scripts/mk/buildapi.mk b/scripts/mk/buildapi.mk
index 6b665f3..3a1f164 100644
--- a/scripts/mk/buildapi.mk
+++ b/scripts/mk/buildapi.mk
@@ -4,11 +4,7 @@ ifndef dpkg_buildapi_mk_included
dpkg_buildapi_mk_included = yes
# Default API level when not set.
-ifndef DPKG_BUILD_API
- dpkg_lazy_eval ?= $(eval $(1) = $(2)$$($(1)))
- dpkg_lazy_set ?= $(call dpkg_lazy_eval,$(1),$$(eval $(1) := $(2)))
- $(call dpkg_lazy_set,DPKG_BUILD_API,$$(shell dpkg-buildapi))
-endif
+DPKG_BUILD_API ?= $(shell dpkg-buildapi)
# We could use only built-in GNU make functions, but that seems too much
# complexity given no integer operators, given that we currently have to