summaryrefslogtreecommitdiffstats
path: root/scripts/mk/buildapi.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:32:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:32:49 +0000
commit9155e8d6752d34e4ea3f022ee51e099420517669 (patch)
tree61c6261279988bba2de9f629a0ee0bd91b45d32f /scripts/mk/buildapi.mk
parentAdding upstream version 1.22.9. (diff)
downloaddpkg-upstream/1.22.10.tar.xz
dpkg-upstream/1.22.10.zip
Adding upstream version 1.22.10.upstream/1.22.10
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/mk/buildapi.mk')
-rw-r--r--scripts/mk/buildapi.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/scripts/mk/buildapi.mk b/scripts/mk/buildapi.mk
index 6b665f3..3a1f164 100644
--- a/scripts/mk/buildapi.mk
+++ b/scripts/mk/buildapi.mk
@@ -4,11 +4,7 @@ ifndef dpkg_buildapi_mk_included
dpkg_buildapi_mk_included = yes
# Default API level when not set.
-ifndef DPKG_BUILD_API
- dpkg_lazy_eval ?= $(eval $(1) = $(2)$$($(1)))
- dpkg_lazy_set ?= $(call dpkg_lazy_eval,$(1),$$(eval $(1) := $(2)))
- $(call dpkg_lazy_set,DPKG_BUILD_API,$$(shell dpkg-buildapi))
-endif
+DPKG_BUILD_API ?= $(shell dpkg-buildapi)
# We could use only built-in GNU make functions, but that seems too much
# complexity given no integer operators, given that we currently have to