summaryrefslogtreecommitdiffstats
path: root/scripts/mk/buildflags.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:31:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:31:20 +0000
commit73d83372ecc1cfc9458fdfdd4bfc591fbe860bca (patch)
tree7ff966e35d1a7105568b835f5b5a19b87045c558 /scripts/mk/buildflags.mk
parentAdding upstream version 1.22.7. (diff)
downloaddpkg-73d83372ecc1cfc9458fdfdd4bfc591fbe860bca.tar.xz
dpkg-73d83372ecc1cfc9458fdfdd4bfc591fbe860bca.zip
Adding upstream version 1.22.8.upstream/1.22.8
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/mk/buildflags.mk')
-rw-r--r--scripts/mk/buildflags.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/mk/buildflags.mk b/scripts/mk/buildflags.mk
index a8eac9e..bc04488 100644
--- a/scripts/mk/buildflags.mk
+++ b/scripts/mk/buildflags.mk
@@ -57,7 +57,7 @@ dpkg_buildflags_run = $(eval $(shell \
$(foreach operation,SET STRIP APPEND PREPEND,\
DEB_$(flag)_MAINT_$(operation))),\
$(if $(value $(exported)),\
- $(exported)="$(value $(exported))"))\
+ $(exported)="$($(exported))"))\
dpkg-buildflags | sed 's/\([^=]*\)\(.*\)/$$(eval \1:\2)/'))
ifdef DPKG_EXPORT_BUILDFLAGS