summaryrefslogtreecommitdiffstats
path: root/scripts/mk/buildtools.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:31:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:31:20 +0000
commit73d83372ecc1cfc9458fdfdd4bfc591fbe860bca (patch)
tree7ff966e35d1a7105568b835f5b5a19b87045c558 /scripts/mk/buildtools.mk
parentAdding upstream version 1.22.7. (diff)
downloaddpkg-73d83372ecc1cfc9458fdfdd4bfc591fbe860bca.tar.xz
dpkg-73d83372ecc1cfc9458fdfdd4bfc591fbe860bca.zip
Adding upstream version 1.22.8.upstream/1.22.8
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--scripts/mk/buildtools.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/scripts/mk/buildtools.mk b/scripts/mk/buildtools.mk
index 1f63bee..def15c1 100644
--- a/scripts/mk/buildtools.mk
+++ b/scripts/mk/buildtools.mk
@@ -28,7 +28,9 @@
ifndef dpkg_buildtools_mk_included
dpkg_buildtools_mk_included = yes
-dpkg_datadir ?= $(dir $(lastword $(MAKEFILE_LIST)))
+ifndef dpkg_datadir
+ dpkg_datadir := $(dir $(lastword $(MAKEFILE_LIST)))
+endif
include $(dpkg_datadir)/architecture.mk
# We set the TOOL_FOR_BUILD variables to the specified value, and the TOOL