summaryrefslogtreecommitdiffstats
path: root/scripts/mk/vendor.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:31:21 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:31:21 +0000
commit75531fca871ac1fd11108fa5852490d7a058c96f (patch)
tree6bb5124fbe313f52ab43084c4e5f09fa4088fe70 /scripts/mk/vendor.mk
parentAdding debian version 1.22.7. (diff)
downloaddpkg-75531fca871ac1fd11108fa5852490d7a058c96f.tar.xz
dpkg-75531fca871ac1fd11108fa5852490d7a058c96f.zip
Merging upstream version 1.22.8.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/mk/vendor.mk')
-rw-r--r--scripts/mk/vendor.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/scripts/mk/vendor.mk b/scripts/mk/vendor.mk
index 43898d9..d257edd 100644
--- a/scripts/mk/vendor.mk
+++ b/scripts/mk/vendor.mk
@@ -36,7 +36,9 @@
ifndef dpkg_vendor_mk_included
dpkg_vendor_mk_included = yes
-dpkg_datadir ?= $(dir $(lastword $(MAKEFILE_LIST)))
+ifndef dpkg_datadir
+ dpkg_datadir := $(dir $(lastword $(MAKEFILE_LIST)))
+endif
include $(dpkg_datadir)/buildapi.mk
dpkg_lazy_eval ?= $(eval $(1) = $(2)$$($(1)))