summaryrefslogtreecommitdiffstats
path: root/scripts/t/mk/pkg-info.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:30:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:30:08 +0000
commit44cf9c6d2d274eac37502e835155f7e985f1b8e6 (patch)
tree9576ba968924c5b9a55ba9e14f4f26184c62c7d4 /scripts/t/mk/pkg-info.mk
parentAdding upstream version 1.22.6. (diff)
downloaddpkg-44cf9c6d2d274eac37502e835155f7e985f1b8e6.tar.xz
dpkg-44cf9c6d2d274eac37502e835155f7e985f1b8e6.zip
Adding upstream version 1.22.7.upstream/1.22.7
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/t/mk/pkg-info.mk')
-rw-r--r--scripts/t/mk/pkg-info.mk31
1 files changed, 23 insertions, 8 deletions
diff --git a/scripts/t/mk/pkg-info.mk b/scripts/t/mk/pkg-info.mk
index c0e3287..6eb3786 100644
--- a/scripts/t/mk/pkg-info.mk
+++ b/scripts/t/mk/pkg-info.mk
@@ -1,11 +1,26 @@
include $(srcdir)/mk/pkg-info.mk
-test:
- test "$(DEB_SOURCE)" = "source"
- test "$(DEB_VERSION)" = "1:2:3.4-5-6"
- test "$(DEB_VERSION_EPOCH_UPSTREAM)" = "1:2:3.4-5"
- test "$(DEB_VERSION_UPSTREAM_REVISION)" = "2:3.4-5-6"
- test "$(DEB_VERSION_UPSTREAM)" = "2:3.4-5"
- test "$(DEB_DISTRIBUTION)" = "suite"
- test '$(SOURCE_DATE_EPOCH)' = '$(TEST_SOURCE_DATE_EPOCH)'
+TEST_DEB_SOURCE = source
+TEST_DEB_VERSION = 1:2:3.4-5-6
+TEST_DEB_VERSION_EPOCH_UPSTREAM = 1:2:3.4-5
+TEST_DEB_VERSION_UPSTREAM_REVISION = 2:3.4-5-6
+TEST_DEB_VERSION_UPSTREAM = 2:3.4-5
+TEST_DEB_DISTRIBUTION = suite
+
+test_vars := \
+ DEB_SOURCE \
+ DEB_VERSION \
+ DEB_VERSION_EPOCH_UPSTREAM \
+ DEB_VERSION_UPSTREAM_REVISION \
+ DEB_VERSION_UPSTREAM \
+ DEB_DISTRIBUTION \
+ SOURCE_DATE_EPOCH \
+ # EOL
+
+test: $(test_vars)
+ : # Test the SOURCE_DATE_EPOCH exported variable.
test "$${SOURCE_DATE_EPOCH}" = '$(TEST_SOURCE_DATE_EPOCH)'
+
+$(test_vars):
+ : # Test the $@ Make variable.
+ test '$($@)' = '$(TEST_$@)'