summaryrefslogtreecommitdiffstats
path: root/tests/Feature.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /tests/Feature.mk
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/Feature.mk')
-rw-r--r--tests/Feature.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/Feature.mk b/tests/Feature.mk
new file mode 100644
index 0000000..da4e8d6
--- /dev/null
+++ b/tests/Feature.mk
@@ -0,0 +1,19 @@
+#
+# Dpkg functional testsuite (kind of)
+#
+# Copyright © 2015 Guillem Jover <guillem@debian.org>
+#
+
+## Feature checks setup ##
+
+ifneq ($(DPKG_FEATURE_CHECKS),yes)
+export DPKG_FEATURE_CHECKS := yes
+
+# XXX: once apt is fixed:
+#export DPKG_HAS_CONFIGURE_WITH_IMPLICIT_TRIGGER_PENDING ?= 1
+
+ifneq (,$(filter as-root,$(DPKG_TESTSUITE_OPTIONS)))
+export DPKG_AS_ROOT = 1
+endif
+
+endif