summaryrefslogtreecommitdiffstats
path: root/tests/t-breaks-essential
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /tests/t-breaks-essential
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tests/t-breaks-essential/Makefile13
-rw-r--r--tests/t-breaks-essential/lib-a-0/DEBIAN/control8
-rw-r--r--tests/t-breaks-essential/lib-a-1/DEBIAN/control8
-rw-r--r--tests/t-breaks-essential/pkg-b/DEBIAN/control8
4 files changed, 37 insertions, 0 deletions
diff --git a/tests/t-breaks-essential/Makefile b/tests/t-breaks-essential/Makefile
new file mode 100644
index 0000000..ace63f0
--- /dev/null
+++ b/tests/t-breaks-essential/Makefile
@@ -0,0 +1,13 @@
+TESTS_DEB := lib-a-0 lib-a-1 pkg-b
+
+include ../Test.mk
+
+DPKG_OPTIONS += --auto-deconfigure
+
+test-case:
+ $(DPKG_INSTALL) lib-a-0.deb
+ $(DPKG_INSTALL) pkg-b.deb lib-a-1.deb
+
+test-clean:
+ $(DPKG_PURGE) pkg-b
+ $(DPKG_PURGE) --force-remove-essential lib-a
diff --git a/tests/t-breaks-essential/lib-a-0/DEBIAN/control b/tests/t-breaks-essential/lib-a-0/DEBIAN/control
new file mode 100644
index 0000000..7643fd8
--- /dev/null
+++ b/tests/t-breaks-essential/lib-a-0/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: lib-a
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Essential: yes
+Description: test package - broken package
diff --git a/tests/t-breaks-essential/lib-a-1/DEBIAN/control b/tests/t-breaks-essential/lib-a-1/DEBIAN/control
new file mode 100644
index 0000000..5c37c03
--- /dev/null
+++ b/tests/t-breaks-essential/lib-a-1/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: lib-a
+Version: 1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Essential: yes
+Description: test package - broken package
diff --git a/tests/t-breaks-essential/pkg-b/DEBIAN/control b/tests/t-breaks-essential/pkg-b/DEBIAN/control
new file mode 100644
index 0000000..c0da700
--- /dev/null
+++ b/tests/t-breaks-essential/pkg-b/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-b
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Breaks: lib-a (<< 1)
+Description: test package - breaking package