summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-forcemiss/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /tests/t-conffile-forcemiss/Makefile
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tests/t-conffile-forcemiss/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/t-conffile-forcemiss/Makefile b/tests/t-conffile-forcemiss/Makefile
new file mode 100644
index 0000000..ab36890
--- /dev/null
+++ b/tests/t-conffile-forcemiss/Makefile
@@ -0,0 +1,16 @@
+TESTS_DEB := pkg-conff-forcemiss-0 pkg-conff-forcemiss-1
+
+include ../Test.mk
+
+test-case:
+ # Test if we get the new conffile after a missing one.
+ $(DPKG_INSTALL) pkg-conff-forcemiss-0.deb
+ $(BEROOT) rm "$(DPKG_INSTDIR)/test-conffile"
+ $(DPKG_INSTALL) pkg-conff-forcemiss-1.deb
+ ! test -f "$(DPKG_INSTDIR)/test-conffile"
+ $(DPKG_INSTALL) --force-confmiss pkg-conff-forcemiss-1.deb
+ cmp ref-conffile "$(DPKG_INSTDIR)/test-conffile"
+ $(DPKG_PURGE) pkg-conff-forcemiss
+
+test-clean:
+ $(DPKG_PURGE) pkg-conff-forcemiss